Вентиляторы видеокарты работают на 100% оборотах (Radeon 7750 на открытых драйверах)

Kubuntu, Xubuntu и другие

Модератор: Модераторы разделов

cv1
Сообщения: 7

Вентиляторы видеокарты работают на 100% оборотах

Сообщение cv1 »

Код: Выделить всё

~$ lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 16.04.1 LTS
Release:    16.04
Codename:    xenial

~$ uname -a
Linux X1 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux



У карты MSI Radeon 7750 два вентилятора, и они работают на полных оборотах.
Шум в простое ужасный.
sensors-detect вентиляторы видеокарты неопределяет, питание на них двупроводное, не PWM (4PIN) или 3 PIN.

Попробовал использовать KMS Power Management :

Код: Выделить всё

~$ cat /sys/class/drm/card0/device/power_method
dpm

~$ echo "dynpm" | sudo tee /sys/class/drm/card0/device/power_method
[sudo] пароль для user:
dynpm
tee: /sys/class/drm/card0/device/power_method: Недопустимый аргумент

~$ echo "profile" | sudo tee /sys/class/drm/card0/device/power_method
profile
tee: /sys/class/drm/card0/device/power_method: Недопустимый аргумент


Но метод почему-то не устанавливается. Помню раньше на ноуте, на Radeon 7640G реально помогало, вентилятор сам утихомиривался вслед за падением температуры после смены метода или профиля.

Ещё пробовал так:

Код: Выделить всё

~$ modinfo -p radeon
no_wb:Disable AGP writeback for scratch registers (int)
modeset:Disable/Enable modesetting (int)
dynclks:Disable/Enable dynamic clocks (int)
r4xx_atom:Enable ATOMBIOS modesetting for R4xx (int)
vramlimit:Restrict VRAM for testing, in megabytes (int)
agpmode:AGP Mode (-1 == PCI) (int)
gartsize:Size of PCIE/IGP gart to setup in megabytes (32, 64, etc., -1 = auto) (int)
benchmark:Run benchmark (int)
test:Run tests (int)
connector_table:Force connector table (int)
tv:TV enable (0 = disable) (int)
audio:Audio enable (-1 = auto, 0 = disable, 1 = enable) (int)
disp_priority:Display Priority (0 = auto, 1 = normal, 2 = high) (int)
hw_i2c:hw i2c engine enable (0 = disable) (int)
pcie_gen2:PCIE Gen2 mode (-1 = auto, 0 = disable, 1 = enable) (int)
msi:MSI support (1 = enable, 0 = disable, -1 = auto) (int)
lockup_timeout:GPU lockup timeout in ms (default 10000 = 10 seconds, 0 = disable) (int)
fastfb:Direct FB access for IGP chips (0 = disable, 1 = enable) (int)
dpm:DPM support (1 = enable, 0 = disable, -1 = auto) (int)
aspm:ASPM support (1 = enable, 0 = disable, -1 = auto) (int)
runpm:PX runtime pm (1 = force enable, 0 = disable, -1 = PX only default) (int)
hard_reset:PCI config reset (1 = force enable, 0 = disable (default)) (int)
vm_size:VM address space size in gigabytes (default 4GB) (int)
vm_block_size:VM page table size in bits (default depending on vm_size) (int)
deep_color:Deep Color support (1 = enable, 0 = disable (default)) (int)
use_pflipirq:Pflip irqs for pageflip completion (0 = disable, 1 = as fallback, 2 = exclusive (default)) (int)
bapm:BAPM support (1 = enable, 0 = disable, -1 = auto) (int)
backlight:backlight support (1 = enable, 0 = disable, -1 = auto) (int)
auxch:Use native auxch experimental support (1 = enable, 0 = disable, -1 = auto) (int)
mst:DisplayPort MST experimental support (1 = enable, 0 = disable) (int)

~$ cat /etc/default/grub |grep DEFAULT
GRUB_DEFAULT=0
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.dpm=1 radeon.msi=1"


Но реакции ноль.
Может кто-что подскажет?

Спасибо сказали:
Аватара пользователя
Bizdelnick
Модератор
Сообщения: 20834
Статус: nulla salus bello
ОС: Debian GNU/Linux

Re: Вентиляторы видеокарты работают на 100% оборотах

Сообщение Bizdelnick »

Возможно, поддержку этой карты ещё не довели до ума. В таком случае остаётся ждать обновления ядра или использовать fglrx.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали:
cv1
Сообщения: 7

Re: Вентиляторы видеокарты работают на 100% оборотах

Сообщение cv1 »

Вообщем оставил

Код: Выделить всё

radeon.dpm=1 radeon.dynclks=1

на всякий случай, а шум уменьшил до минимума просто перепаяв соединения вентиляторов с параллельного на последовательное.

Вентиляторы запускаются, карта прогревается на открытых драйверах в Metro 2033 до 56-60, в простое 39 градусов (до этого на полных оборотах было 34)

Bizdelnick писал(а):
22.01.2017 22:36
Возможно, поддержку этой карты ещё не довели до ума. В таком случае остаётся ждать обновления ядра или использовать fglrx.


fglrx помер, есть amdgpu, который 7750 не поддерживает, а на x.org/wiki/RadeonFeature/ написано что доступа к вентиляторам нет, да и опасно это.

Controlling the fan speed directly is not possible (and would be very dangerous), but it can be lowered by setting lower power profile.
Спасибо сказали:
Аватара пользователя
Bizdelnick
Модератор
Сообщения: 20834
Статус: nulla salus bello
ОС: Debian GNU/Linux

Re: Вентиляторы видеокарты работают на 100% оборотах

Сообщение Bizdelnick »

cv1 писал(а):
22.01.2017 22:44
fglrx помер

Действительно, в xenial его уже нет. Прошу прощения.
Пишите правильно:
в консоли
вку́пе (с чем-либо)
в общем
вообще
в течение (часа)
новичок
нюанс
по умолчанию
приемлемо
проблема
пробовать
трафик
Спасибо сказали: