После первой установки неработает и-нет

Kubuntu, Xubuntu и другие

Модератор: Модераторы разделов

dtaras
Сообщения: 16
ОС: Mandriva

После первой установки неработает и-нет

Сообщение dtaras » 21.02.2018 19:13

Приветствую всех!
Ставил Xubuntu 16.o4 с галкой "установить обновления" после чего не работает сетевое соединение
выводы команд

Код: Выделить всё

ifconfig -a
enp3s0    Link encap:Ethernet  HWaddr d4:3d:7e:04:66:90
          inet addr:172.30.106.218  Bcast:172.30.106.255  Mask:255.255.255.0
          inet6 addr: fe80::3a60:701d:16c0:4d5b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:41 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3676 (3.6 KB)  TX bytes:5394 (5.3 KB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:396 errors:0 dropped:0 overruns:0 frame:0
          TX packets:396 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:31628 (31.6 KB)  TX bytes:31628 (31.6 KB)

и

Код: Выделить всё

sudo cat /etc/network/interfaces
auto enp3s0
iface enp3s0 inet dhcp

Как исправить?
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 14129
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: После первой установки неработает и-нет

Сообщение Bizdelnick » 21.02.2018 19:27

Интернет работает, проблема на Вашей стороне. ☺
Сетевое соединение тоже, очевидно, работает: интерфейс поднялся, адрес получил, пакеты приходят и уходят. Описывайте подробно симптомы проблемы, начиная с того, как вообще должно настраиваться подключение, пингуется ли шлюз и т. д.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

dtaras
Сообщения: 16
ОС: Mandriva

Re: После первой установки неработает и-нет

Сообщение dtaras » 21.02.2018 19:54

Bizdelnick писал(а):
21.02.2018 19:27
Интернет работает, проблема на Вашей стороне. ☺
Сетевое соединение тоже, очевидно, работает: интерфейс поднялся, адрес получил, пакеты приходят и уходят. Описывайте подробно симптомы проблемы, начиная с того, как вообще должно настраиваться подключение, пингуется ли шлюз и т. д.

При первом включении не смог зайти в и-нет. Огнелис пишет "сервер не найден". До этого была установлена lubuntu 12.04, где все работало.
Нард пишет, что network-manager с глюками.в обновлении. Теперь нужно или как-то откатиться или выкинуть Xubunu и ставить что-то другое :(
Попробывал пинг

Код: Выделить всё

ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=46 time=32.7 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=46 time=32.7 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=46 time=32.9 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=46 time=32.8 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=46 time=32.7 ms
--- 8.8.8.8 ping statistics ---
9 packets transmitted, 9 received, 0% packet loss, time 8008ms
rtt min/avg/max/mdev = 32.747/32.802/32.953/0.159 ms

Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 14129
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: После первой установки неработает и-нет

Сообщение Bizdelnick » 21.02.2018 20:27

dtaras писал(а):
21.02.2018 19:54
Огнелис пишет "сервер не найден".

Так, может, просто DNS не пашет? Покажите, что в /etc/resolv.conf.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

dtaras
Сообщения: 16
ОС: Mandriva

Re: После первой установки неработает и-нет

Сообщение dtaras » 21.02.2018 20:50

Так, может, просто DNS не пашет? Покажите, что в /etc/resolv.conf.


Код: Выделить всё

/etc/network/interface
auto enp0s3
iface enp0s3 inet dhcp

Если добавляю
dns-nameservice 8.8.8.8
то network service не запускается после перегрузки (sudo service networking restart)


Спасибо сказали:

Аватара пользователя
ieleja
Сообщения: 307
ОС: Debian 9, macOS, Windows

Re: После первой установки неработает и-нет

Сообщение ieleja » 21.02.2018 22:01

dtaras писал(а):
21.02.2018 20:50
Если добавляю
dns-nameservice 8.8.8.8
то network service не запускается после перегрузки (sudo service networking restart)


Код: Выделить всё

sudo echo nameserver 8.8.8.8 > /etc/resolv.conf


или в /etc/network/interface

Код: Выделить всё

dns-nameservers 8.8.8.8
ad infinitum
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 14129
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: После первой установки неработает и-нет

Сообщение Bizdelnick » 21.02.2018 23:38

Bizdelnick писал(а):
21.02.2018 20:27
Покажите, что в /etc/resolv.conf

Безо всяких манипуляций с ним и с interfaces. Вручную прописывать DNS смысла нет (разве что временно), он должен получаться по DHCP. Надо разобраться, почему этого не происходит.
Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

dtaras
Сообщения: 16
ОС: Mandriva

Re: После первой установки неработает и-нет

Сообщение dtaras » 21.02.2018 23:42

Вроде помогла запись

Код: Выделить всё

sudo echo nameserver 8.8.8.8 > /etc/resolv.conf

После перезагрузки и обновления проверю работоспособность.
Спасибо сказали:

Аватара пользователя
Bizdelnick
Модератор
Сообщения: 14129
Статус: grammatikführer
ОС: Debian GNU/Linux

Re: После первой установки неработает и-нет

Сообщение Bizdelnick » 21.02.2018 23:56

dtaras писал(а):
21.02.2018 23:42
После перезагрузки и обновления проверю работоспособность.

Не переживёт она перезагрузку. Ещё раз повторяю:
Bizdelnick писал(а):
21.02.2018 23:38
Вручную прописывать DNS смысла нет (разве что временно), он должен получаться по DHCP. Надо разобраться, почему этого не происходит.

Пишите правильно:
в консоли
вкупе (с чем-либо)
в общем
вообще
в течение (часа)
команда
новичок
нюанс
приемлемо
проблема
пробовать
трафик
Спасибо сказали:

dtaras
Сообщения: 16
ОС: Mandriva

Re: После первой установки неработает и-нет

Сообщение dtaras » 22.02.2018 01:08

Спасибо за советы. Посмотрю, что сохранилось.
Перегрузку пережил, сеть работает.
Спасибо сказали:

Вернуться в «Ubuntu Linux»