RDESKTOP

Cent OS, Scientific Linux

Модератор: Модераторы разделов

Аватара пользователя
123456
Сообщения: 490

RDESKTOP

Сообщение 123456 »

Пытаюсь подключиться к серверу Windows NT, выдает следущее:

SOZ@localhost ~]$ rdesktop -u sash -d fis -p XXXXX 192.168.XXX.XXX
ERROR: 192.168.XXX.XXX: unable to connect


В чем дело :unsure:
Спасибо сказали:
Аватара пользователя
sash-kan
Администратор
Сообщения: 13939
Статус: oel ngati kameie
ОС: GNU

Re: RDESKTOP

Сообщение sash-kan »

123456
а на сервере служба соответствующая запущена? и т.д. и т.п.

telnet <сервер> 3389
отрабатывает?
Писать безграмотно - значит посягать на время людей, к которым мы адресуемся, а потому совершенно недопустимо в правильно организованном обществе. © Щерба Л. В., 1957
при сбоях форума см.блог
Спасибо сказали:
bugel
Сообщения: 225

Re: RDESKTOP

Сообщение bugel »

сервак пингуется? ;)
С уважением, bugel
Спасибо сказали:
Аватара пользователя
123456
Сообщения: 490

Re: RDESKTOP

Сообщение 123456 »

sash-kan писал(а): ↑
12.12.2006 17:40
123456
а на сервере служба соответствующая запущена? и т.д. и т.п.

telnet <сервер> 3389
отрабатывает?


[SOZ@localhost ~]$ telnet 192.168.XXX.XXX 3389
Trying 192.168.XXX.XXX...
telnet: connect to address 192.168.XXX.XXX: Connection refused
telnet: Unable to connect to remote host: Connection refused
[SOZ@localhost ~]$

Какую службу надо запускать?
И надо устанавливать для этого RAS?:(
Спасибо сказали:
Аватара пользователя
Семен
Сообщения: 6
ОС: FreeBSD 6.3, Fedora 8

Re: RDESKTOP

Сообщение Семен »

123456 писал(а): ↑
13.12.2006 11:08
[SOZ@localhost ~]$ telnet 192.168.XXX.XXX 3389
Trying 192.168.XXX.XXX...
telnet: connect to address 192.168.XXX.XXX: Connection refused
telnet: Unable to connect to remote host: Connection refused
[SOZ@localhost ~]$

Какую службу надо запускать?
И надо устанавливать для этого RAS?:(

RAS - не надо, оно не для того.
На той стороне как минимум должна функционировать служба терминалов и быть разрешен доступ к удаленному рабочему столу.
Сейчас все выглядит так, словно либо служба не запущена, либо хост вообще не отвечает.
Что насчет пинга на него? (см. пост от bugel выше)
Спасибо сказали:
Аватара пользователя
123456
Сообщения: 490

Re: RDESKTOP

Сообщение 123456 »

(Семен @ Dec 13 2006, в 11:54) писал(а):RAS - не надо, оно не для того.
На той стороне как минимум должна функционировать служба терминалов и быть разрешен доступ к удаленному рабочему столу.
Сейчас все выглядит так, словно либо служба не запущена, либо хост вообще не отвечает.
Что насчет пинга на него? (см. пост от bugel выше)


[SOZ@localhost ~]$ ping 192.168.XXX.XXX
PING 192.168.XXX.XXX (192.168.XXX.XXX) 56(84) bytes of data.
64 bytes from 192.168.XXX.XXX: icmp_seq=1 ttl=128 time=1.24 ms
64 bytes from 192.168.XXX.XXX: icmp_seq=2 ttl=128 time=0.236 ms
64 bytes from 192.168.XXX.XXX: icmp_seq=3 ttl=128 time=0.219 ms


--- 192.168.XXX.XXX ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 5999ms
rtt min/avg/max/mdev = 0.215/0.374/1.242/0.355 ms
[SOZ@localhost ~]$
Спасибо сказали:
Аватара пользователя
Семен
Сообщения: 6
ОС: FreeBSD 6.3, Fedora 8

Re: RDESKTOP

Сообщение Семен »

123456 писал(а): ↑
13.12.2006 12:09
[SOZ@localhost ~]$ ping 192.168.XXX.XXX
PING 192.168.XXX.XXX (192.168.XXX.XXX) 56(84) bytes of data.
64 bytes from 192.168.XXX.XXX: icmp_seq=1 ttl=128 time=1.24 ms
64 bytes from 192.168.XXX.XXX: icmp_seq=2 ttl=128 time=0.236 ms
64 bytes from 192.168.XXX.XXX: icmp_seq=3 ttl=128 time=0.219 ms


--- 192.168.XXX.XXX ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 5999ms
rtt min/avg/max/mdev = 0.215/0.374/1.242/0.355 ms
[SOZ@localhost ~]$

Вопрос про пинг снят :D
Почему не телнетится на 3389 порт? Если все ОК - должно телнетиться.
Какой-нибудь фаервол по дороге не режет порт tcp 3389?
Служба терминалов на винде запущена?
Удаленное управление рабочим столом разрешено?
С какой-нибудь другой виндовс можно присоединиться к удаленному столу?

ЗЫ можно пробовать просто rdesktop 192.168.XXX.XXX, это уже должно бы открыть окно для логина.
Спасибо сказали:
Аватара пользователя
123456
Сообщения: 490

Re: RDESKTOP

Сообщение 123456 »

(Семен @ Dec 13 2006, в 12:18) писал(а):Служба терминалов на винде запущена?
Удаленное управление рабочим столом разрешено?


Не могу найти где это смотреть????
Спасибо сказали:
Аватара пользователя
Семен
Сообщения: 6
ОС: FreeBSD 6.3, Fedora 8

Re: RDESKTOP

Сообщение Семен »

123456 писал(а): ↑
13.12.2006 13:05
Не могу найти где это смотреть????

Start -> Settings -> Control Panel -> Administrative Tools -> Services
Пуск -> Настройка -> Панель управления -> Администрирование -> Службы
В списке должны быть службы терминалов (Terminal Services) в запущенном состоянии.
Если сервак WS2003, то правый клик на "мой компьютер" -> свойства, там есть вкладка, посвященная удаленному управлению рабочим столом, такая же, как в XP.
В случае W2k Server - читайте сюда.
Про NT4 Server ничего не скажу ибо не знаю :)

забанят нас за злостный оффтопик :)
Спасибо сказали:
Аватара пользователя
123456
Сообщения: 490

Re: RDESKTOP

Сообщение 123456 »

(Семен @ Dec 13 2006, в 13:17) писал(а):Про NT4 Server ничего не скажу ибо не знаю

Прочитал что для NT есть отдельный продукт, называется Terminal Server Edition.
Но откуда его качнуть пока не нашел :lol:
Спасибо сказали:
Аватара пользователя
123456
Сообщения: 490

Re: RDESKTOP

Сообщение 123456 »

Я уже понял, что это другая ОС "Windows NT Server 4.0, Terminal Server Edition".
Так что воспользоваться RDESKTOP не удасться а через VNC что-то уж очень медленно работает.
Спасибо сказали:
Аватара пользователя
Семен
Сообщения: 6
ОС: FreeBSD 6.3, Fedora 8

Re: RDESKTOP

Сообщение Семен »

123456 писал(а): ↑
13.12.2006 17:07
Я уже понял, что это другая ОС "Windows NT Server 4.0, Terminal Server Edition".
Так что воспользоваться RDESKTOP не удасться а через VNC что-то уж очень медленно работает.

Есть вариант - утилитка Remote Administrator (RAdmin). По-моему, серверная часть работает на любых виндах. Клиентская часть (вьювер) после пары ударов в бубен заработает в любом *NIX (через Wine), сам когда-то использовал. Скорость работы удовлетворительная, хотя и чуток помедленнее, чем rdesktop (оно и понятно...)
В любом случае, если нужно только удаленное администрирование - нет смысла связываться с Terminal Server Edition.

ЗЫ Вариант апгрейда сервера хотя бы до win2k не рассматривается? ;)
Спасибо сказали:
Аватара пользователя
123456
Сообщения: 490

Re: RDESKTOP

Сообщение 123456 »

(Семен @ Dec 14 2006, в 05:46) писал(а):ЗЫ Вариант апгрейда сервера хотя бы до win2k не рассматривается?


Как сертификацию win2k пройдет так перейдем на нее.
Спасибо сказали:
Аватара пользователя
DaemonTux
Сообщения: 1480
Статус: Юный падаван
ОС: Gentoo

Re: RDESKTOP

Сообщение DaemonTux »

Используй радми. Только клиента я под никсами через вине не запускал. А вообще штука хорошая мне лично очень нравиться.
Vladivostok Linux User Group
Спасибо сказали:
denge
Сообщения: 5
ОС: Fedora Core 6

Re: RDESKTOP

Сообщение denge »

При попытки соединица по RDP (Через клиент Терминального Сервера или с командной строки) , получаю следующее сообщение..

disconnect: No valid license available.


Лицензии нет ?

В лицензии Клиента Терм. Сервера следующее..

Terminal Server Client is licensed under the
GNU General Public License (GPL)
<http://www.gnu.org/licenses/gpl.html>


Как только поставил Систему, клиент работал.. теперь же нет..
Спасибо сказали:
Аватара пользователя
sash-kan
Администратор
Сообщения: 13939
Статус: oel ngati kameie
ОС: GNU

Re: RDESKTOP

Сообщение sash-kan »

(denge @ Dec 20 2006, в 12:33) писал(а):disconnect: No valid license available.
сдается мне, это сообщение от windows. со всеми вытекающими. денежек они хотятс... вполне здоровое желание...
Писать безграмотно - значит посягать на время людей, к которым мы адресуемся, а потому совершенно недопустимо в правильно организованном обществе. © Щерба Л. В., 1957
при сбоях форума см.блог
Спасибо сказали: