pidgin (не запускается)

Джаббер, аська и прочее

Модератор: /dev/random

Аватара пользователя
PolecatZZZ
Сообщения: 258
ОС: Debian 6

pidgin

Сообщение PolecatZZZ »

В графическом режиме запускаю - он начинает грузиться, загрузка продолжается несколько секунд и прекращается. приложение не запускается. Подскажите, в чём может быть причина, куда копать?
OpenSUSE >>> Debian
Спасибо сказали:
Аватара пользователя
SLEDopit
Модератор
Сообщения: 4813
Статус: фанат консоли (=
ОС: GNU/Debian, RHEL

Re: pidgin

Сообщение SLEDopit »

PolecatZZZ писал(а):
02.01.2009 19:35
В графическом режиме запускаю - рн начинает грузиться, загрузка продолжается несколько секунд и прекращается. приложение не запускается. Подскажите, в чём может быть причина, куда копать?
откройте консоль, напишите там pidgin и нажмиие enter. все ошибки которые вылезут - запостите сюда, если сами не разберетесь :)
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity. © Dennis Ritchie
The more you believe you don't do mistakes, the more bugs are in your code.
Спасибо сказали:
Аватара пользователя
PolecatZZZ
Сообщения: 258
ОС: Debian 6

Re: pidgin

Сообщение PolecatZZZ »

SLEDopit писал(а):
02.01.2009 19:44
PolecatZZZ писал(а):
02.01.2009 19:35
В графическом режиме запускаю - рн начинает грузиться, загрузка продолжается несколько секунд и прекращается. приложение не запускается. Подскажите, в чём может быть причина, куда копать?
откройте консоль, напишите там pidgin и нажмиие enter. все ошибки которые вылезут - запостите сюда, если сами не разберетесь :)

Код: Выделить всё

Expected libotr API version 3.2.0 incompatible with actual version 3.1.0.  Aborting.

google предложил исправить слово libotr
OpenSUSE >>> Debian
Спасибо сказали:
Аватара пользователя
SLEDopit
Модератор
Сообщения: 4813
Статус: фанат консоли (=
ОС: GNU/Debian, RHEL

Re: pidgin

Сообщение SLEDopit »

попробуйте поставить версию pidgin'a поновее.
ну или обновите libotr (по моему в списке пакетов он должен быть записан как libotr2).
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity. © Dennis Ritchie
The more you believe you don't do mistakes, the more bugs are in your code.
Спасибо сказали:
Аватара пользователя
PolecatZZZ
Сообщения: 258
ОС: Debian 6

Re: pidgin

Сообщение PolecatZZZ »

SLEDopit писал(а):
02.01.2009 19:52
попробуйте поставить версию pidgin'a поновее.
ну или откатите libotr (по моему в списке пакетов он должен быть записан как libotr2) на 3.1.0.

хм... пиджин заработал после обновления как раз таки самого libotr. А не подскажите - для чего он нужен и где про него можно поподробней почитать?
OpenSUSE >>> Debian
Спасибо сказали:
Аватара пользователя
SLEDopit
Модератор
Сообщения: 4813
Статус: фанат консоли (=
ОС: GNU/Debian, RHEL

Re: pidgin

Сообщение SLEDopit »

UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity. © Dennis Ritchie
The more you believe you don't do mistakes, the more bugs are in your code.
Спасибо сказали:
Inesauribile
Сообщения: 1

Re: pidgin

Сообщение Inesauribile »

Expected libotr API version 3.2.0 incompatible with actual version 3.1.0. Aborting.


Это именно и обозначает:
«Ожидается версия 3.2.0, а есть лишь 3.1.0»
Спасибо сказали:
Аватара пользователя
ukrop
Сообщения: 136
ОС: Debian Squeeze

Re: pidgin

Сообщение ukrop »

скомпилил pidgin-2.5.4 :angry: а он негодяй, не стартанул
Решилось так
#sudo ln -s /usr/local/lib/libpurple.so.0 /usr/lib/
...однако, промахнулись
Спасибо сказали:
Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: pidgin

Сообщение Bluetooth »

ukrop писал(а):
22.01.2009 14:53
скомпилил pidgin-2.5.4 :angry: а он негодяй, не стартанул
Решилось так
#sudo ln -s /usr/local/lib/libpurple.so.0 /usr/lib/
...однако, промахнулись

по-моему это вы промахнулись при компиляции :) или у вас система не настроена на то, чтоб либы смотреть в /usr/local/lib :)
Спасибо сказали:
Аватара пользователя
ukrop
Сообщения: 136
ОС: Debian Squeeze

Re: pidgin

Сообщение ukrop »

по-моему это вы промахнулись при компиляции :) или у вас система не настроена на то, чтоб либы смотреть в /usr/local/lib :)

ну ответ на свой вопрос я в иннете отловил, т.ч. не у меня одного
тем не мение, чего почитать по поводу \"не настроена на то, чтоб либы смотреть в /usr/local/lib\"?
кстати, настроена на то, чтоб либы смотреть в /usr/local/lib , GIMP там имеется и работает
Спасибо сказали:
Аватара пользователя
l2ping
Сообщения: 49
ОС: Debian GNU/Linux

Re: pidgin

Сообщение l2ping »

Устанавливаю из исходников pidgin 2.5.4 с официального сайта pidgin.im ... выполняю команду ./configure , выдаёт что нада либо установить gstreamer, или скомандомать ./configure --disable--gstreamer (примерно так, точно не помню)... в общем к целую кучу библиотек (так наверное это называется) программа при конфигурировании не находит... хотя он установлены... Подскажите где нужно прописать пути к этим библиотекам, что б прири конфигурировании они были определены ? Только не советуйте устанавливать из .rpm пакетов, я с установкой из исходных текстов хочу разобраься.
Мы можем всё, просто мы ещё этого не знаем...
Спасибо сказали:
Аватара пользователя
/dev/random
Администратор
Сообщения: 5160
ОС: Gentoo

Re: pidgin

Сообщение /dev/random »

l2ping писал(а):
04.02.2009 13:21
Устанавливаю из исходников pidgin 2.5.4 с официального сайта pidgin.im ... выполняю команду ./configure , выдаёт что нада либо установить gstreamer, или скомандомать ./configure --disable--gstreamer (примерно так, точно не помню)... в общем к целую кучу библиотек (так наверное это называется) программа при конфигурировании не находит... хотя он установлены... Подскажите где нужно прописать пути к этим библиотекам, что б прири конфигурировании они были определены ? Только не советуйте устанавливать из .rpm пакетов, я с установкой из исходных текстов хочу разобраься.

*-dev (*-devel) пакеты для этих библиотек установлены?
Спасибо сказали:
Аватара пользователя
l2ping
Сообщения: 49
ОС: Debian GNU/Linux

Re: pidgin

Сообщение l2ping »

/dev/random писал(а):
04.02.2009 13:51
*-dev (*-devel) пакеты для этих библиотек установлены?

вечером посмотрю
Мы можем всё, просто мы ещё этого не знаем...
Спасибо сказали:
Аватара пользователя
l2ping
Сообщения: 49
ОС: Debian GNU/Linux

Re: pidgin

Сообщение l2ping »

*-dev (*-devel) пакеты для этих библиотек установлены?

понял где рыть ))) установил я pidgin. :) всем спасибо :)
Мы можем всё, просто мы ещё этого не знаем...
Спасибо сказали:
Аватара пользователя
ukrop
Сообщения: 136
ОС: Debian Squeeze

Re: pidgin

Сообщение ukrop »

*просматриваю свои прошлые посты . вот и до этого добрёл...
Bluetooth писал(а):
22.01.2009 17:16
по-моему это вы промахнулись при компиляции

теперь то вижу как :crazy:

а всё пАтамуША нужно

Код: Выделить всё

./configure --prefix=/usr
Спасибо сказали: