*напортачил с либами ((так еще ниразу не попадал))

Cent OS, Scientific Linux

Модератор: Модераторы разделов

Аватара пользователя
Doka
Сообщения: 715
Статус: ASIC Design Engineer
ОС: RHEL4

*напортачил с либами

Сообщение Doka »

система - CentOS 5.2 x86_64
всё началось с подключения репозитария EPEL и того что я инсталлировал оттуда некоторые бибилиотеки (wxBase, wxGTK* и какие-то еще, которые тянули зависимости).
при этом на машине уже были установлены собранные вручную wxBase|wxGTK, wxWidgets.

после всего этого при каждом обновлении системы получал ворох таких вот предупреждений (скроллить):

Код:

$ sudo yum update Loading "changelog" plugin Loading "kernel-module" plugin Loading "tsflags" plugin Loading "fastestmirror" plugin Loading "priorities" plugin Loading "downloadonly" plugin Loading "allowdowngrade" plugin Loading "skip-broken" plugin Loading "protectbase" plugin Loading mirror speeds from cached hostfile * epel: dispenser.yandex.net * base: mirror.yandex.ru * updates: ftp.funet.fi * addons: mirror.yandex.ru * extras: mirror.yandex.ru epel 100% |=========================| 2.1 kB 00:00 primary.sqlite.bz2 100% |=========================| 2.6 MB 00:01 base 100% |=========================| 1.1 kB 00:00 updates 100% |=========================| 951 B 00:00 primary.xml.gz 100% |=========================| 427 kB 00:00 updates : ################################################## 944/944 addons 100% |=========================| 951 B 00:00 extras 100% |=========================| 1.1 kB 00:00 0 packages excluded due to repository priority protections 0 packages excluded due to repository protections Setting up Update Process Resolving Dependencies --> Running transaction check ---> Package avahi-compat-howl.i386 0:0.6.16-1.el5_2.1 set to be updated ---> Package avahi-qt3.i386 0:0.6.16-1.el5_2.1 set to be updated ---> Package squirrelmail.noarch 0:1.4.8-5.el5.centos.2 set to be updated ---> Package krb5-server.x86_64 0:1.6.1-25.el5_2.2 set to be updated ---> Package krb5-devel.i386 0:1.6.1-25.el5_2.2 set to be updated ---> Package avahi-glib.i386 0:0.6.16-1.el5_2.1 set to be updated ---> Package avahi-glib.x86_64 0:0.6.16-1.el5_2.1 set to be updated ---> Package krb5-libs.i386 0:1.6.1-25.el5_2.2 set to be updated ---> Package drupal.noarch 0:5.15-1.el5 set to be updated ---> Package avahi-devel.x86_64 0:0.6.16-1.el5_2.1 set to be updated ---> Package krb5-devel.x86_64 0:1.6.1-25.el5_2.2 set to be updated ---> Package krb5-workstation.x86_64 0:1.6.1-25.el5_2.2 set to be updated ---> Package avahi.i386 0:0.6.16-1.el5_2.1 set to be updated ---> Package avahi.x86_64 0:0.6.16-1.el5_2.1 set to be updated ---> Package krb5-libs.x86_64 0:1.6.1-25.el5_2.2 set to be updated ---> Package avahi-qt3.x86_64 0:0.6.16-1.el5_2.1 set to be updated ---> Package avahi-compat-howl.x86_64 0:0.6.16-1.el5_2.1 set to be updated --> Finished Dependency Resolution Dependencies Resolved ============================================================================= Package Arch Version Repository Size ============================================================================= Updating: avahi i386 0.6.16-1.el5_2.1 updates 250 k avahi x86_64 0.6.16-1.el5_2.1 updates 255 k avahi-compat-howl i386 0.6.16-1.el5_2.1 updates 29 k avahi-compat-howl x86_64 0.6.16-1.el5_2.1 updates 29 k avahi-devel x86_64 0.6.16-1.el5_2.1 updates 38 k avahi-glib i386 0.6.16-1.el5_2.1 updates 14 k avahi-glib x86_64 0.6.16-1.el5_2.1 updates 14 k avahi-qt3 i386 0.6.16-1.el5_2.1 updates 17 k avahi-qt3 x86_64 0.6.16-1.el5_2.1 updates 17 k drupal noarch 5.15-1.el5 epel 797 k krb5-devel i386 1.6.1-25.el5_2.2 updates 1.9 M krb5-devel x86_64 1.6.1-25.el5_2.2 updates 1.9 M krb5-libs i386 1.6.1-25.el5_2.2 updates 658 k krb5-libs x86_64 1.6.1-25.el5_2.2 updates 666 k krb5-server x86_64 1.6.1-25.el5_2.2 updates 911 k krb5-workstation x86_64 1.6.1-25.el5_2.2 updates 901 k squirrelmail noarch 1.4.8-5.el5.centos.2 updates 4.3 M Transaction Summary ============================================================================= Install 0 Package(s) Update 17 Package(s) Remove 0 Package(s) Total download size: 13 M Downloading Packages: (1/17): avahi-compat-howl 100% |=========================| 29 kB 00:00 (2/17): avahi-qt3-0.6.16- 100% |=========================| 17 kB 00:00 (3/17): krb5-libs-1.6.1-2 100% |=========================| 666 kB 00:00 (4/17): avahi-0.6.16-1.el 100% |=========================| 255 kB 00:00 (5/17): avahi-0.6.16-1.el 100% |=========================| 250 kB 00:00 (6/17): krb5-workstation- 100% |=========================| 901 kB 00:00 (7/17): krb5-devel-1.6.1- 100% |=========================| 1.9 MB 00:04 (8/17): avahi-devel-0.6.1 100% |=========================| 38 kB 00:00 (9/17): drupal-5.15-1.el5 100% |=========================| 797 kB 00:00 http://ftp.funet.fi/pub/mirrors/centos.org...5_2.2.i386.rpm: [Errno 14] HTTP Error 503: Service Temporarily Unavailable Trying other mirror. (10/17): krb5-libs-1.6.1- 100% |=========================| 658 kB 00:00 (11/17): avahi-glib-0.6.1 100% |=========================| 14 kB 00:00 (12/17): avahi-glib-0.6.1 100% |=========================| 14 kB 00:00 (13/17): krb5-devel-1.6.1 100% |=========================| 1.9 MB 00:03 (14/17): krb5-server-1.6. 100% |=========================| 911 kB 00:00 (15/17): squirrelmail-1.4 100% |=========================| 4.3 MB 00:08 (16/17): avahi-qt3-0.6.16 100% |=========================| 17 kB 00:00 (17/17): avahi-compat-how 100% |=========================| 29 kB 00:00 Running rpm_check_debug Running Transaction Test Finished Transaction Test Transaction Test Succeeded Running Transaction Updating : avahi ####################### [ 1/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Updating : krb5-libs ####################### [ 2/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Updating : avahi ####################### [ 3/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Updating : krb5-libs ####################### [ 4/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. warning: /etc/krb5.conf created as /etc/krb5.conf.rpmnew Updating : avahi-glib ####################### [ 5/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Updating : avahi-qt3 ####################### [ 6/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Updating : avahi-compat-howl ####################### [ 7/34] Updating : krb5-server ####################### [ 8/34] Updating : krb5-devel ####################### [ 9/34] Updating : krb5-workstation ####################### [10/34] warning: /etc/sysconfig/krb524 created as /etc/sysconfig/krb524.rpmnew Updating : avahi-compat-howl ####################### [11/34] Updating : avahi-qt3 ####################### [12/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Updating : avahi-glib ####################### [13/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Updating : squirrelmail ####################### [14/34] Updating : krb5-devel ####################### [15/34] warning: /etc/profile.d/krb5-devel.csh created as /etc/profile.d/krb5-devel.csh.rpmnew warning: /etc/profile.d/krb5-devel.sh created as /etc/profile.d/krb5-devel.sh.rpmnew Updating : drupal ####################### [16/34] Updating : avahi-devel ####################### [17/34] Cleanup : avahi-compat-howl ####################### [18/34] Cleanup : avahi-qt3 ####################### [19/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Cleanup : squirrelmail ####################### [20/34] Cleanup : krb5-server ####################### [21/34] Cleanup : krb5-devel ####################### [22/34] Cleanup : avahi-glib ####################### [23/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Cleanup : avahi-glib ####################### [24/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Cleanup : krb5-libs ####################### [25/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Cleanup : drupal ####################### [26/34] Cleanup : avahi-devel ####################### [27/34] Cleanup : krb5-devel ####################### [28/34] Cleanup : krb5-workstation ####################### [29/34] Cleanup : avahi ####################### [30/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Cleanup : avahi ####################### [31/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Cleanup : krb5-libs ####################### [32/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Cleanup : avahi-qt3 ####################### [33/34] /sbin/ldconfig: libraries libwx_baseu-2.8.so.0.1.1 and libwx_baseu-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_aui-2.8.so.0.1.1 and libwx_gtk2u_aui-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_baseu_net-2.8.so.0.1.1 and libwx_baseu_net-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_core-2.8.so.0.1.1 and libwx_gtk2u_core-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. /sbin/ldconfig: libraries libwx_gtk2u_adv-2.8.so.0.1.1 and libwx_gtk2u_adv-2.8.so.0.5.0 in directory /usr/lib have same soname but different type. Cleanup : avahi-compat-howl ####################### [34/34] Updated: avahi.i386 0:0.6.16-1.el5_2.1 avahi.x86_64 0:0.6.16-1.el5_2.1 avahi-compat-howl.i386 0:0.6.16-1.el5_2.1 avahi-compat-howl.x86_64 0:0.6.16-1.el5_2.1 avahi-devel.x86_64 0:0.6.16-1.el5_2.1 avahi-glib.i386 0:0.6.16-1.el5_2.1 avahi-glib.x86_64 0:0.6.16-1.el5_2.1 avahi-qt3.i386 0:0.6.16-1.el5_2.1 avahi-qt3.x86_64 0:0.6.16-1.el5_2.1 drupal.noarch 0:5.15-1.el5 krb5-devel.i386 0:1.6.1-25.el5_2.2 krb5-devel.x86_64 0:1.6.1-25.el5_2.2 krb5-libs.i386 0:1.6.1-25.el5_2.2 krb5-libs.x86_64 0:1.6.1-25.el5_2.2 krb5-server.x86_64 0:1.6.1-25.el5_2.2 krb5-workstation.x86_64 0:1.6.1-25.el5_2.2 squirrelmail.noarch 0:1.4.8-5.el5.centos.2 Complete!


ладно бы это было самое печальное, ну так нет же!...
теперь я не могу запустить собранный из исходников и давно используемый на этом хосте aMule:

Код: Выделить всё

$ amuled
amuled: OnInit - starting timer
Initialising aMule
Checking if there is an instance already running...
No other instances are running.
Loading temp files from /emule/temp.
..
<skip>
...
Loading PartFile 134 of 137: ERROR: Failed to load PartFile '96.part.met'
Loading PartFile 135 of 137: ERROR: Failed to load PartFile '97.part.met'
Loading PartFile 136 of 137: ERROR: Failed to load PartFile '98.part.met'
Loading PartFile 137 of 137: ERROR: Failed to load PartFile '99.part.met'

All PartFiles Loaded.
ListenSocket: Could not listen to TCP port.ERROR: Error Port 4662 is not available!

This means that you will be LOWID.

Check your network to make sure the port is open for output and input.

*** TCP socket (ECServer) listening on 0.0.0.0:4712
*** Server UDP socket (TCP+3) at 0.0.0.0:4665
*** TCP socket (TCP) listening on 0.0.0.0:4662
Port 4662 is not available. You will be LOWID
*** Client UDP socket (extended eMule) at 0.0.0.0:4672
Empty dir /emule/incoming/ shared
        aMule Version: aMuled 2.1.3 using wxGTK2 v2.8.7

Terminated after throwing an instance of 'CryptoPP::OS_RNG_Err'
        what(): OS_Rng: open /dev/urandom operation failed with error 24
        backtrace:
[2] ?? in amuled [0x417125]
[3] wxEntry(int&, char**) in /usr/local/lib/libwx_base-2.8.so.0[0x2b0ba84f7f52]
[4] ?? in amuled [0x40ddc2]
[5] __libc_start_main in /lib64/libc.so.6[0x335d81d8b4]
[6] ?? in amuled [0x40d879]

Aborted


после чего с горя деинсталлировал злочастные пакеты через yum, но aMule так и не смог запуститься...


вопросы
1. что произошло ?
2. как теперь вернуть всё назад? (работающий aMule)
Never stop thinking..................................................................
Спасибо сказали:
krege
Сообщения: 669
ОС: Fedora 21 x86_64 / KDE 5

Re: *напортачил с либами

Сообщение krege »

Doka писал(а):
19.01.2009 13:57
как теперь вернуть всё назад? (работающий aMule)

Пересобрать.

Doka писал(а):
19.01.2009 13:57
после чего с горя деинсталлировал злочастные пакеты через yum

Собранные из исходников устанавливались в /usr/local? Если в /usr, то они так же удалились через yum, хотя, возможно, что частично.

Используя исходники, выполните make uninstall того, что:
Doka писал(а):
19.01.2009 13:57
на машине уже были установлены собранные вручную wxBase|wxGTK, wxWidgets

с теми же префиксами, что использовались для make install. Затем установите этии пакеты через yum. После чего пересборка (или подобная установка через yum с предварительной чисткой) должна решить проблему.
Спасибо сказали:
Аватара пользователя
Doka
Сообщения: 715
Статус: ASIC Design Engineer
ОС: RHEL4

Re: *напортачил с либами

Сообщение Doka »

отчитываюсь:

>> Собранные из исходников устанавливались в /usr/local?

собранные из исходников устанавливал в "путь по умолчанию"


>> Используя исходники, выполните make uninstall

там вариант make distclean сработал вроде, но проблема в том, что сами библиотеки не удалились (почему-то).

пришлось делать так:
1) деинсталлировал через yum
2)

Код: Выделить всё

locate libwx
rm -rf /usr/local/lib/libwx*
rm -rf /usr/lib/libwx*
yum install wxGTK.x86_64 wxGTK-devel.x86_64 wxBase-devel.x86_64
Never stop thinking..................................................................
Спасибо сказали:
krege
Сообщения: 669
ОС: Fedora 21 x86_64 / KDE 5

Re: *напортачил с либами

Сообщение krege »

Doka писал(а):
28.01.2009 11:17
make distclean сработал вроде,

Ох... Если написано uninstall, зачем делать distclean? Это совершенно разные вещи. distclean очищает _исходники_ от скомпилированного и наконфигурированного, а uninstall удаляет установленное в систему.
Спасибо сказали:
Аватара пользователя
Doka
Сообщения: 715
Статус: ASIC Design Engineer
ОС: RHEL4

Re: *напортачил с либами

Сообщение Doka »

krege

ну щас не вспомню..
значит не было там такого target rule как uninstall..
Never stop thinking..................................................................
Спасибо сказали:
krege
Сообщения: 669
ОС: Fedora 21 x86_64 / KDE 5

Re: *напортачил с либами

Сообщение krege »

В WxWigets нет uninstall? Не может быть.
Спасибо сказали: