Sabayon, Calculate, Funtoo, Exherbo
Модератор: /dev/random
Xaktyc
Сообщения: 604
ОС: Gentoo 2008.0, WinXP
Сообщение
Xaktyc » 09.03.2009 20:33
Собрал гентуху, инет идет через встроенную сетевую карту на гигабит на матери Asus p5b.
Тут все работает, никаких замечаний. Проблема в том, что не работает вторая сетевуха:
Код: Выделить всё
skobkin xak # lspci | grep Realtek
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
05:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
Первая - как раз через которую в инете по PPPOE. Вторую не видит ни ifconfig ни гуевый менеджер настройки.
Код: Выделить всё
skobkin xak # ifconfig
eth0 Link encap:Ethernet HWaddr 00:18:f3:9a:8c:8b
inet addr:10.114.6.14 Bcast:10.114.6.255 Mask:255.255.255.0
inet6 addr: fe80::218:f3ff:fe9a:8c8b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4741100 errors:0 dropped:0 overruns:0 frame:0
TX packets:5310737 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3266002922 (3.0 GiB) TX bytes:3239413431 (3.0 GiB)
Interrupt:123
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
...
[и еще тут пппое]
Примечательно, что у друга собравшего генту на своем компе тоже не работает вторая сетевуха (Smc ez card ). При этом он даже вкомпилил поддержку SMC. У меня же нету поддержки Realtek в 10 и 100мегабитных девайсах.
Xaktyc
Сообщения: 604
ОС: Gentoo 2008.0, WinXP
Сообщение
Xaktyc » 09.03.2009 20:52
/etc/conf.d/net
Код: Выделить всё
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d. To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
config_eth0=( "dhcp" )
dhcp_eth0="nontp nonis"
config_eth1=( "192.168.0.1 netmask 255.255.255.0" )
dhcp_eth1="nodns nontp nonis"
#dns_domain_lo="skobkin.ru"
skobkin xak # rc-update add net.eth1 default
* rc-update: service `net.eth1' does not exist
Походу интерфейса просто нету.. что делать?
abs-o-lut
Сообщения: 420
Сообщение
abs-o-lut » 09.03.2009 21:28
Интерфейсы из воздуха должны браться?
# ifconfig -a чтобы посмотреть все интерфейсы
или
# ifconfig eth1 up чтобы поднять eth
Если есть eth1(eth2 или т.п.), то
# cp /etc/init.d/net.lo /etc/init.d/net.eth1
если нет интерфейса, то разбираться с ядерным модулем на сетевую.
Xaktyc
Сообщения: 604
ОС: Gentoo 2008.0, WinXP
Сообщение
Xaktyc » 09.03.2009 22:00
Прошу не нервничать. Все настроено, не спрашивал бы.
Код: Выделить всё
skobkin xak # ifconfig eth1 up
eth1: ERROR while getting interface flags: Нет такого устройства
skobkin xak # ls /etc/init.d/ | grep net
net.eth0
net.eth1
net.lo
netmount
xinetd
abs-o-lut
Сообщения: 420
Сообщение
abs-o-lut » 09.03.2009 22:03
А показать
# ifconfig -a
Xaktyc
Сообщения: 604
ОС: Gentoo 2008.0, WinXP
Сообщение
Xaktyc » 09.03.2009 22:05
Пожалуйста
Код: Выделить всё
skobkin xak # ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:18:f3:9a:8c:8b
inet addr:10.114.6.14 Bcast:10.114.6.255 Mask:255.255.255.0
inet6 addr: fe80::218:f3ff:fe9a:8c8b/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:103951 errors:0 dropped:0 overruns:0 frame:0
TX packets:166929 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:18435420 (17.5 MiB) TX bytes:140194559 (133.6 MiB)
Interrupt:123
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1001 errors:0 dropped:0 overruns:0 frame:0
TX packets:1001 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:61372 (59.9 KiB) TX bytes:61372 (59.9 KiB)
ppp0 Link encap:Point-to-Point Protocol
inet addr:62.192.240.64 P-t-P:62.192.224.113 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1492 Metric:1
RX packets:102830 errors:0 dropped:0 overruns:0 frame:0
TX packets:166496 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:16103137 (15.3 MiB) TX bytes:136503797 (130.1 MiB)
sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
tunl0 Link encap:IPIP Tunnel HWaddr
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
alexxy
Сообщения: 11
ОС: Gentoo GNU/Linux
Сообщение
alexxy » 09.03.2009 22:37
Мда... Топикстартера видать в гугле забанили.
Если спросить у гугла первое что он говрит так это что сия карточка поддерживается драйвером NE 2000 =)
Топикстартер дальше сам осилит догадаться что надо сделать?
Gentoo Team Ru Leading Coordinator
Gentoo Dev
yaleks
Сообщения: 2121
Статус: вне статуса
ОС: Gentoo ~
Сообщение
yaleks » 09.03.2009 22:43
abs-o-lut писал(а): ↑ 09.03.2009 21:28
Если есть eth1(eth2 или т.п.), то
# cp /etc/init.d/net.lo /etc/init.d/net.eth1
никогда не надо давать таких советов, симлинк надо делать, иначе при обновлении всё отвалится и долго будете выяснять причину.
abs-o-lut
Сообщения: 420
Сообщение
abs-o-lut » 09.03.2009 23:07
Да, вы правы, это я дал маху, конечно же ln -s
Xaktyc
Сообщения: 604
ОС: Gentoo 2008.0, WinXP
Сообщение
Xaktyc » 10.03.2009 00:09
Учтемс, ща сделаю, за драйвер спасибо. Ценные сведенья, ща буду проверять.
Xaktyc
Сообщения: 604
ОС: Gentoo 2008.0, WinXP
Сообщение
Xaktyc » 10.03.2009 18:24
Все, заработало. Спасибо за подсказку.