Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Джаббер, аська и прочее

Модератор: /dev/random

Аватара пользователя
mist404
Сообщения: 106
ОС: Free Mandriva 2009

Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение mist404 »

Народ сей час зашёл Pidgin (2.5.1) , а он гад не заходит не в аську, не в irc, требует обновить до 2.5.5, не хочу её обновлять (у меня мандрива, а из сорцов собирать долго), можно ли не обнавляя старую версию юзать?
Спасибо сказали:
Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Bluetooth »

ну, в аську понятно почему не войти - алкаши из АОЛ постоянно протокол меняют. а в чем проблема с irc?
Спасибо сказали:
cyxou
Сообщения: 125
ОС: Ubuntu 16.04.1 LTS 64

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение cyxou »

обновился до 2.5.5, ниже версии не пускает ссылаясь на сайт с просьбой обновить клиента. протокол работает
Спасибо сказали:
MiK13
Сообщения: 1062
ОС: Linux Debian

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение MiK13 »

А кто-нибудь вообще пытался разобраться с причиной такой работы разных клиентов ICQ?
Почему, когда QIP перестал работать, ссылаясь на изменение протокола и заработал только после обновления, старын версии &RQ и Miranda-IM работали без проблем? Причём такое проиходило не один раз (2 точно).
И тепершняя ситуация -- вдруг у меня перестал работать pidgin (версия, вроде, 2.4.3-4 -- та, что в Lenny)
Причём, похоже, это относится только к этому клиенту -- другие клиенты работают нормально
Если бы это касалось изменения протоколоа, то, IMHO, ситуация должна была бы быть другой
Спасибо сказали:
Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Bluetooth »

А кто-нибудь вообще пытался разобраться с причиной такой работы разных клиентов ICQ?
Почему, когда QIP перестал работать, ссылаясь на изменение протокола и заработал только после обновления, старын версии &RQ и Miranda-IM работали без проблем? Причём такое проиходило не один раз (2 точно).
И тепершняя ситуация -- вдруг у меня перестал работать pidgin (версия, вроде, 2.4.3-4 -- та, что в Lenny)
Причём, похоже, это относится только к этому клиенту -- другие клиенты работают нормально
Если бы это касалось изменения протоколоа, то, IMHO, ситуация должна была бы быть другой

если вам интересно, то погуглите на эту тему. а вообще, разработчики пиджина, видимо, не юзают сами аську(правильно, кстати, делают), поэтому они никогда не спешат с фиксами дял работы аськи, в отличие от создателей квипа)
а насчет старых версий миранды, сима и прочих - интересная ситуация, видимо, АОЛовцы не могут грамотно отрезать всех, а отрезают частично, да и то, плохо))
Спасибо сказали:
Аватара пользователя
/dev/random
Администратор
Сообщения: 5160
ОС: Gentoo

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение /dev/random »

Bluetooth писал(а):
10.03.2009 00:05
а насчет старых версий миранды, сима и прочих - интересная ситуация, видимо, АОЛовцы не могут грамотно отрезать всех, а отрезают частично, да и то, плохо))

Где-то проскальзывало мнение, что они это делают специально. Во-первых, то появляющийся, то исчезающий баг сложнее исправить. Во-вторых, это позволяет вместо создания глобальных перебоев, которые можно переждать, сделать сторонние клиенты в глазах юзеров "глючными".
Спасибо сказали:
Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Bluetooth »

/dev/random писал(а):
10.03.2009 00:11
Bluetooth писал(а):
10.03.2009 00:05
а насчет старых версий миранды, сима и прочих - интересная ситуация, видимо, АОЛовцы не могут грамотно отрезать всех, а отрезают частично, да и то, плохо))

Где-то проскальзывало мнение, что они это делают специально. Во-первых, то появляющийся, то исчезающий баг сложнее исправить. Во-вторых, это позволяет вместо создания глобальных перебоев, которые можно переждать, сделать сторонние клиенты в глазах юзеров "глючными".

а мне кажется это банальный "недосмотр", ибо в АОЛ небезосновательно сделали выводы, что не нужно отрезать старые клиенты, ибо они малораспространены. в свою очередь старые клиенты имеют реализацию только основных функций протокола, а вносить изменение в фундаментальные функции протокола с целью отрезать чужие клиенты - не самая лучшая идея, куда лучше внести изменения в какую-нибудь глупость, и на основании этого отрезать клиентов.
ну, данное виденье проблемы не подкреплено ничем - я не видел в исходникач ни одной реализации протокола аськи. просто такой вариант дял меня выглядит логичным.
Спасибо сказали:
Аватара пользователя
mist404
Сообщения: 106
ОС: Free Mandriva 2009

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение mist404 »

В irc , зашел, там у меня небольшая проблема с настройками была, а вот аська так и не работает (даже на kopete), есть совесть, зачем протокол каждый раз обновлять, при этом требовать нувую версию !
Спасибо сказали:
Аватара пользователя
SilentOS
Сообщения: 251
Статус: Важный воевода
ОС: SuSE

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение SilentOS »

mist404 писал(а):
10.03.2009 14:33
зачем протокол каждый раз обновлять, при этом требовать нувую версию !

Для того, чтобы сознательные пиплы начинали jabber использовать.
Спасибо сказали:
Dyx
Сообщения: 6
ОС: Fedora 8

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Dyx »

Ни кто не знает когда появится 2.5.5 для Fedor'ы 8 (что бы через yum обновить можно было)?
Или где можно скачать уже?
Спасибо сказали:
Gyzma
Сообщения: 43
ОС: Debian Squeeze/Sid

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Gyzma »

обновил, всё заработало...
Есть такая профессия HeroПортер!
Спасибо сказали:
Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Bluetooth »

mist404 писал(а):
10.03.2009 14:33
В irc , зашел, там у меня небольшая проблема с настройками была, а вот аська так и не работает (даже на kopete), есть совесть, зачем протокол каждый раз обновлять, при этом требовать нувую версию !

чтобы люди юзали официальный клиент)
Спасибо сказали:
tierpunk
Сообщения: 78
ОС: Ubuntu, Debian, Centos

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение tierpunk »

http://www.getdeb.net/app/Pidgin
там есть новая версия под дебиан/убунту
проверено на убунту 8.10 - работает.
Спасибо за то что ответили на моё сообщение.
Спасибо сказали:
BuuG
Сообщения: 7
ОС: F10

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение BuuG »

Dyx писал(а):
10.03.2009 16:37
Ни кто не знает когда появится 2.5.5 для Fedor'ы 8 (что бы через yum обновить можно было)?
Или где можно скачать уже?


Незнаю как в 8-е, я в 10-е обнавился из тестого репозитория, полет нормальный
для 386:

Код: Выделить всё

rpm -Uvh http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/10/i386/pidgin-2.5.5-1.fc10.i386.rpm http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/10/i386/libpurple-2.5.5-1.fc10.i386.rpm

для 64:

Код: Выделить всё

rpm -Uvh http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/10/x86_64/pidgin-2.5.5-1.fc10.x86_64.rpm http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/10/x86_64/libpurple-2.5.5-1.fc10.x86_64.rpm
Спасибо сказали:
Dyx
Сообщения: 6
ОС: Fedora 8

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Dyx »

да, для 10 работает, сам попробовал.
Но нужно для 8 ещё :-)
Спасибо сказали:
Аватара пользователя
Kont
Сообщения: 22
ОС: ubuntu 8.10

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Kont »

Bluetooth писал(а):
10.03.2009 00:27
а мне кажется это банальный "недосмотр", ибо в АОЛ небезосновательно сделали выводы, что не нужно отрезать старые клиенты, ибо они малораспространены. в свою очередь старые клиенты имеют реализацию только основных функций протокола, а вносить изменение в фундаментальные функции протокола с целью отрезать чужие клиенты - не самая лучшая идея, куда лучше внести изменения в какую-нибудь глупость, и на основании этого отрезать клиентов.
ну, данное виденье проблемы не подкреплено ничем - я не видел в исходникач ни одной реализации протокола аськи. просто такой вариант дял меня выглядит логичным.

Все проблемы с изменениями в протоколе были для того что бы пользователи из странн СНГ стали пользоваться оффициальном клиентом ICQ.Ведь в их клиенте есть реклама, которая приносит им прибыль, а если в СНГ почти все используют альтернативные клиенты, то прибыль уменьшается, а на нагрузка на сервер остается та же самая.По этому они начали блокировать тех у кого клиент не определялся как ICQ 5.1.Ведь у американских посетителей сайта icq.com, на главной странице отображалось предложение скачать новую версию ICQ....
Спасибо сказали:
Benden
Сообщения: 83
ОС: (K)Ubuntu 10.10 amd64

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Benden »

http://www.getdeb.net/app/Pidgin
там есть новая версия под дебиан/убунту

Там только убунтовские дебы... они для Дебиана подойдут? и от какой - intrepid или hardy - брать для lenny?
Спасибо сказали:
Аватара пользователя
Encore
Сообщения: 656
Статус: loading..............
ОС: Debian

Re: Pidgin 2.5.1 - можно ли использовать, но не обновлять?

Сообщение Encore »

Benden писал(а):
14.03.2009 02:53
http://www.getdeb.net/app/Pidgin
там есть новая версия под дебиан/убунту

Там только убунтовские дебы... они для Дебиана подойдут? и от какой - intrepid или hardy - брать для lenny?

В соседней теме про Pidgin писал - с репозиториев Debian (sid) можно поставить 2.5.5
Спасибо сказали: