Возникла у меня следующая проблема:
После настройки sendmail в качестве smtp сервера на FC6, почту можно отправлять только с самого сервера, т.е.
Код: Выделить всё
telnet smtp.server 25
Trying IP...
Connected to smtp.server (IP).
Escape character is '^]'.
220 localhost.localdomain ESMTP
EHLO smtp.server
250-localhost.localdomain Hello [IP], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-DELIVERBY
250 HELP
mail from:admin@microsoft.com
250 2.1.0 admin@microsoft.com... Sender ok
rcpt to:lirik@yandex.ru
250 2.1.5 lirik@yandex.ru... Recipient ok
DATA
354 Enter mail, end with "." on a line by itself
subject: Test
test test test
.
250 2.0.0 m1H8bY2i003885 Message accepted for delivery
QUIT
Connection closed by foreign host.Т.е. почта отправлена и все отлично.
Sendmail настроен без авторизации, т.к. в идеале он должен лишь отправлять почту и общаться лишь с определенными IP.
файл устроен таким образом:
Код: Выделить всё
Connect:localhost.localdomain RELAY
Connect:localhost RELAY
Connect:127.0.0.1 RELAY
Connect:10.0.1.2 RELAY
IP OKВсе эти данный занесены в /etc/mail/access.db
далее я перезагружаю sendmail
Код: Выделить всё
Останавливается sm-client: [ СБОЙ ]
Останавливается sendmail: [ OK ]
Запускается sendmail: [ OK ]
Запускается sm-client: [ OK ]После чего я пытаюсь отправить сообщение с IP через этот smtp сервер и получаю:
Код: Выделить всё
telnet smtp.server 25
Trying IP...
Connected to smtp.server.
Escape character is '^]'.
220 localhost.localdomain ESMTP
EHLO smtp.server
250-localhost.localdomain Hello IP, pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-DELIVERBY
250 HELP
mail from:admin@microsoft.com
250 2.1.0 admin@microsoft.com... Sender ok
rcpt to:i@yandex.ru
550 5.7.1 i@yandex.ru... Relaying denied
........
[code]
cat /var/log/mailing
Feb 17 11:34:24 svibl sendmail[3818]: m1H8UUOr003818: ruleset=check_rcpt, arg1=i@yandex.ru, relay=IP, reject=550 5.7.1 i@yandex.ru... Relaying deniedнаверно проблема возникает из-за того что не запускается sm-client.
Люди добрые подскажите куда копать, На опеннете скоро банить будут.