Apache виден только локально

Обсуждение настройки и работы сервисов, резервирования, сетевых настроек и вопросов безопасности ОС.

Модераторы: SLEDopit, Модераторы разделов

ssamm
Сообщения: 45
ОС: Fedora 14

Apache виден только локально

Сообщение ssamm »

Помогите сил моих больше нет :(
локально страница Apache открывается и по localhost и по 127.0.0.1, а с других компьютеров до него достучаться никак не могу.
пробовал через telnet, пишет: telnet: connect to address 192.168.0.10: No route to host

netstate говорит

Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 16665/httpd


файервол отрублен
[root@rezserver init.d]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT icmp -- anywhere anywhere
ACCEPT all -- anywhere anywhere
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
target prot opt source destination
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

ничего не понимаю!!!
Спасибо сказали:
Аватара пользователя
Voral
Сообщения: 1205
ОС: Debian Wheezy (amd64)

Re: Apache виден только локально

Сообщение Voral »

В самом апаче есть настройка на каком интерфейсе "слушать".
Смотрите

NameVirtualHost возможно у вас что то типа NameVirtualHost 127.0.0.1:80
Или в настройках конкретного виртульного хоста <VirtualHost 127.0.0.1:80>
не?
То что не убивает нас, делает нас сильнее! © Ницше.
When life puts you in tough situations, don’t say "why me". Just say "try me © ?
Спасибо сказали:
ssamm
Сообщения: 45
ОС: Fedora 14

Re: Apache виден только локально

Сообщение ssamm »

Voral писал(а): ↑
30.07.2010 15:54
В самом апаче есть настройка на каком интерфейсе "слушать".
Смотрите

NameVirtualHost возможно у вас что то типа NameVirtualHost 127.0.0.1:80
Или в настройках конкретного виртульного хоста <VirtualHost 127.0.0.1:80>
не?


насчет интерфейса (если имеется ввиду сетевой адаптер) в конфиге ничего не нашел

а все строки касательно VirtualHost закомментированы
Спасибо сказали:
neol
Сообщения: 600
ОС: Debian Stable

Re: Apache виден только локально

Сообщение neol »

ssamm писал(а): ↑
30.07.2010 15:40
пробовал через telnet, пишет: telnet: connect to address 192.168.0.10: No route to host

Дайте-ка я угадаю: апач стоит в виртуалке и связи по сети с этой виртуалкой вообще нет?
Спасибо сказали:
ssamm
Сообщения: 45
ОС: Fedora 14

Re: Apache виден только локально

Сообщение ssamm »

neol писал(а): ↑
30.07.2010 16:31
ssamm писал(а): ↑
30.07.2010 15:40
пробовал через telnet, пишет: telnet: connect to address 192.168.0.10: No route to host

Дайте-ка я угадаю: апач стоит в виртуалке и связи по сети с этой виртуалкой вообще нет?


нет отдельный выделенный сервер в локальной сети, сейчас там работает 60 чел в терминале, а вот апач никак отвечать не хочет
Спасибо сказали:
neol
Сообщения: 600
ОС: Debian Stable

Re: Apache виден только локально

Сообщение neol »

ssamm писал(а): ↑
30.07.2010 16:38
нет отдельный выделенный сервер в локальной сети, сейчас там работает 60 чел в терминале, а вот апач никак отвечать не хочет

Покажите ifconfig и route с сервера и клиента. Если где-то Windows, то ipconfig /all и route print.
Спасибо сказали:
ssamm
Сообщения: 45
ОС: Fedora 14

Re: Apache виден только локально

Сообщение ssamm »

вот, сервак:

Код: Выделить всё

[root@rezserver init.d]# ifconfig
eth0      Link encap:Ethernet  HWaddr 48:5B:39:05:59:0B
          inet addr:192.168.0.113  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::4a5b:39ff:fe05:590b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4084046 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8538219 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:407211352 (388.3 MiB)  TX bytes:8823569124 (8.2 GiB)
          Interrupt:56 Base address:0xe000

eth1      Link encap:Ethernet  HWaddr 48:5B:39:05:56:E9
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::4a5b:39ff:fe05:56e9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13186632 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27614768 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1700905235 (1.5 GiB)  TX bytes:27994004076 (26.0 GiB)
          Interrupt:57 Base address:0xc000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:30962501 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30962501 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:35593512380 (33.1 GiB)  TX bytes:35593512380 (33.1 GiB)

[root@rezserver init.d]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     1      0        0 eth0
192.168.0.0     *               255.255.255.0   U     1      0        0 eth1
default         192.168.0.4     0.0.0.0         UG    0      0        0 eth0

клиент:

Код: Выделить всё

[nout@nout ~]$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1E:33:50:67:B7
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:28 Base address:0xc000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:920 (920.0 b)  TX bytes:920 (920.0 b)

wlan0     Link encap:Ethernet  HWaddr 00:16:44:F0:A9:E7
          inet addr:192.168.0.6  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::216:44ff:fef0:a9e7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:47889 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32059 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:22334103 (21.2 MiB)  TX bytes:5678272 (5.4 MiB)

[nout@nout ~]$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     2      0        0 wlan0
default         192.168.0.4     0.0.0.0         UG    0      0        0 wlan0
Спасибо сказали:
neol
Сообщения: 600
ОС: Debian Stable

Re: Apache виден только локально

Сообщение neol »

Может так вы достучитесь до апача:
telnet 192.168.0.113 80

И нафига у вас два адреса из одной подсети
ssamm писал(а): ↑
30.07.2010 16:56
eth0 Link encap:Ethernet HWaddr 48:5B:39:05:59:0B
inet addr:192.168.0.113 Bcast:192.168.0.255 Mask:255.255.255.0

ssamm писал(а): ↑
30.07.2010 16:56
eth1 Link encap:Ethernet HWaddr 48:5B:39:05:56:E9
inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0

куда воткнут кабель из eth1 и как по вашему это все вообще должно работать?
Спасибо сказали:
ssamm
Сообщения: 45
ОС: Fedora 14

Re: Apache виден только локально

Сообщение ssamm »

второй был не задействован, это уже я предположил, что вдруг он интерфейс eth0 слушает, вот и прицепил его к тому-же коммутатору под другим IP, не помогло, telnet сдесь также отвечает. Правильно ли я понимаю что раз telnet отвечает: No route to host, то значит что, файерволл пакеты пропускает и э\то проблема апача?
Спасибо сказали:
neol
Сообщения: 600
ОС: Debian Stable

Re: Apache виден только локально

Сообщение neol »

ssamm писал(а): ↑
30.07.2010 17:42
Правильно ли я понимаю что раз telnet отвечает: No route to host, то значит что, файерволл пакеты пропускает и э\то проблема апача?

Это означает, что ваш комп не может найти маршрут до сервера. Данная проблема к апачу вообще никакого отношения не имеет. Надо смотреть что есть между вами и сервером и как оно настроено. ИМХО проще спросить у того, кто это все делал, если есть такая возможность.

Для очистки совести посмотрите пинг до сервера. Если пройдет, будем вместе ничего не понимать (:
Спасибо сказали:
Аватара пользователя
sash-kan
Администратор
Сообщения: 13939
Статус: oel ngati kameie
ОС: GNU

Re: Apache виден только локально

Сообщение sash-kan »

ssamm писал(а): ↑
30.07.2010 17:42
Правильно ли я понимаю что раз telnet отвечает: No route to host, то значит что, файерволл пакеты пропускает и э\то проблема апача?
нет, неправильно понимаете. no route to host переводится как «нет маршрута к указанной машине».
Писать безграмотно - значит посягать на время людей, к которым мы адресуемся, а потому совершенно недопустимо в правильно организованном обществе. © Щерба Л. В., 1957
при сбоях форума см.блог
Спасибо сказали:
ssamm
Сообщения: 45
ОС: Fedora 14

Re: Apache виден только локально

Сообщение ssamm »

neol писал(а): ↑
30.07.2010 18:14
ssamm писал(а): ↑
30.07.2010 17:42
Правильно ли я понимаю что раз telnet отвечает: No route to host, то значит что, файерволл пакеты пропускает и э\то проблема апача?

Это означает, что ваш комп не может найти маршрут до сервера. Данная проблема к апачу вообще никакого отношения не имеет. Надо смотреть что есть между вами и сервером и как оно настроено. ИМХО проще спросить у того, кто это все делал, если есть такая возможность.

Для очистки совести посмотрите пинг до сервера. Если пройдет, будем вместе ничего не понимать (:


Дык, я все это как раз и настраиваю, поднимаю резервный сервер (на основном сейчас все нормально работает), да и на этом крутится nxserver и в терминале сейчас работают люди, т.е. как-то этот хост же находится? и пинги идут без всяких потерь, а телнетом никак не получчается на 80-й порт подключится ни с какой машины, при этом на 22-й к SSH цепляюсь без проблем (только что проверил) хм, попробую пойду апач на другой порт повешу...
а между мной и сервером ничего, коммутатор в который воткнуты все компы.
Причем до того как я на этот сервак людей запустил, проверял апач работал (примерно месяца два назад) вроде ничего такого не делал, только разве что IP сетевого интерфейса сменил
Спасибо сказали:
ssamm
Сообщения: 45
ОС: Fedora 14

Re: Apache виден только локально

Сообщение ssamm »

повесил на порт 10387 и те-же грабли, уже не знаю куда копать, кстати по VNC тоже не получается подключится :( и ведь то-же работало...
хм, попробовал другие порты, например 25, там sendmail висит, тоже не цепляется, что за ерунда...
Наткнулся тут на описание подобной ошибки, исходя из него, насколько я понял "No rout to host", не обязательно говорит о том что не может найти такой хост:
https://bugzilla.redhat.com/show_bug.cgi?id=490854
Спасибо сказали:
Аватара пользователя
sash-kan
Администратор
Сообщения: 13939
Статус: oel ngati kameie
ОС: GNU

Re: Apache виден только локально

Сообщение sash-kan »

1. на машине, к которой пытаетесь подключиться, очистите правила netfilter-а (в просторечии — отключите файерволл).
2. на той же машине запустите tcpdump или tshark:
$ sudo tshark -pni <сетевой интерфейс> port 80
3. на другой машине в сети запустите:
$ telnet <один из ip адресов, закреплённых за интерфейсом из предыдущего пункта> 80
4. смотрите в выдаче tshark, приходят ли запросы и уходят ли ответы.
Писать безграмотно - значит посягать на время людей, к которым мы адресуемся, а потому совершенно недопустимо в правильно организованном обществе. © Щерба Л. В., 1957
при сбоях форума см.блог
Спасибо сказали:
ssamm
Сообщения: 45
ОС: Fedora 14

Re: Apache виден только локально

Сообщение ssamm »

sash-kan писал(а): ↑
31.07.2010 12:25
1. на машине, к которой пытаетесь подключиться, очистите правила netfilter-а (в просторечии — отключите файерволл).
2. на той же машине запустите tcpdump или tshark:
$ sudo tshark -pni <сетевой интерфейс> port 80
3. на другой машине в сети запустите:
$ telnet <один из ip адресов, закреплённых за интерфейсом из предыдущего пункта> 80
4. смотрите в выдаче tshark, приходят ли запросы и уходят ли ответы.


Ай спасибо мил человек, выручил (просто особо раньше с этим никогда не сталкивался), в графическом интерфейсе файервол отключен, вывод листинга "iptables -L" я выше показывал, вроде ничего криминального там не было.
сейчас запустил на серваке tcpdump -i eth1 host 192.168.0.6
и пытаясь подключится с другой машины увидел картину:

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 65535 bytes
14:37:07.745179 IP 192.168.0.6.54208 > 192.168.0.10.10387: Flags [S], seq 2641046403, win 5840, options [mss 1460,sackOK,TS val 21385989 ecr 0,nop,wscale 6], length 0
14:37:07.745200 IP 192.168.0.10 > 192.168.0.6: ICMP host 192.168.0.10 unreachable - admin prohibited, length 68

ну все стало ясно проблема с файерволом, дал команду iptables -F и наконец увидел на удаленном компе ответ апача!!!

только непонятно откудова всетаки брались правила iptables я их вообще нигде не настраивал
Спасибо сказали: