Wine и видеокамера (Подключение к приложению видеокамеры)

Вопросы настройки, запуск любых Windows-программ, кроме игр

Модератор: Модераторы разделов

ank1960
Сообщения: 2
ОС: MS WinXP home

Wine и видеокамера

Сообщение ank1960 »

Доброго времени суток

Прощу помощи.

Я установил в SUSE 10.1 видеокамеру Logitech QuickCam Pro 5000 и с помощью luvcview камера выдает изображение на экран (так как надо)

Необходимо, чтобы эта камера работала в виндовом приложении. Автоматически это не получается, по интернету поискал, подсказок не нашел.
Спасибо сказали:

Hoblin
Модератор
Сообщения: 1442
Статус: Etersoft team
ОС: ALT Linux

Re: Wine и видеокамера

Сообщение Hoblin »

ank1960 писал(а):
20.09.2007 09:24
Я установил в SUSE 10.1 видеокамеру Logitech QuickCam Pro 5000 и с помощью luvcview камера выдает изображение на экран (так как надо)
Необходимо, чтобы эта камера работала в виндовом приложении. Автоматически это не получается, по интернету поискал, подсказок не нашел.

Чем помочь, даже не знаю... Видел множество обсуждений работы камер в wine, в том числе и здесь на форуме. Все сводятся к тому, что это невозможно.
Спасибо сказали:

ank1960
Сообщения: 2
ОС: MS WinXP home

Re: Wine и видеокамера

Сообщение ank1960 »

Есть виндовая программа, которая тестирует подключение оборудования. Фрагмент выдачи тестовой информации в консоль линукса следующий:
Device N 1
UVC Camera (046d:08c5)
fixme:qcap:VfwPin_QueryInterface No interface for {c6e13340-30ac-11d0-a18c-00a0c9118956}!
Try connect to UVC Camera (046d:08c5) ... fixme:qcap:VfwPin_QueryInterface No interface for {c6e13340-30ac-11d0-a18c-00a0c9118956}!
fixme:qcap:VfwPin_QueryInterface No interface for {c6e13340-30ac-11d0-a18c-00a0c9118956}!
Fail !
Спасибо сказали:

mr_owl
Сообщения: 1
ОС: debian etch

Re: Wine и видеокамера

Сообщение mr_owl »

ank1960 писал(а):
20.09.2007 10:38
fixme:qcap:VfwPin_QueryInterface No interface for {c6e13340-30ac-11d0-a18c-00a0c9118956}!


бьюсь над проблемой уже неделю.
уже бросил бы, если б не один момент:
при запуске виндового вьювера хоть и вылезают
подобные ошибки, но начинает светиться индикатор
на камере. Можно сделать предположение, что
редирект на девайс все же происходит, но поток
данных несколько отличается от ожидаемого.
В какую сторону копать ? или все-таки смысла нет ???
Спасибо сказали: