Проблема с автомонтированием NTFS(драйвер ntfs-3g)

openSUSE, SUSE Linux Enterprise

Модераторы: k0da, Goodvin, Модераторы разделов

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 12.11.2007 19:40

Знаю, тема перемывалась не раз, был в поиске, прочитал огромное количество тем и руководств, но ответа не нашел :)

Итак, имеется юсб хард с НТФС разделом, монтируется на ура, но только на чтение, я из консоли монтировал с помошью НТФС-3Г, работало и на чтение и на запись, но хотелось чтоб монтировалось сразу на чтение и запись, погуглив, нашел вот это:
http://gentoo-wiki.com/HOWTO_NTFS_write_with_ntfs-3g

Use ntfs-3g instead of ntfs in AutoMounting

If you would like to always use ntfs-3g (especially with automounting in KDE) there are several ways to do this. Here they are in order of when they were added to this wiki, take your pick. Some of them might be obsolete now.
[edit]
Create pseudo mount.ntfs binary

As root do:
# ln -s /usr/bin/ntfs-3g /sbin/mount.ntfs

Now when a NTFS filesystem is found, mount will use load ntfs-3g's "mounter".

Выполнил что было написано, не помогло, зашел в /sbin/, а рядом там как раз валялся файл "mount.ntfs-3g", ссылающийся у да же куда и эта сиволическая ссылка, ну я его скопировал и переименовал в mount.ntfs - заработало!
Все стало монтироваться на чтение и запись, но проблема в другом - не видны файлы и папки, названные по-русски в винде, но при этом при монтировании из консоли с использованием той же самой утилиты - они видны!!!
В принципе я знаю как лечится отсуствие русских файлов, делал это заданием параметров в fstab, но в данном случае после добваления строчки в fstab у меня вылетае отшибка при попытке монтирования - пишет "error opening partition device"
вот строчка в fstab(само отображение русских файлов еще не настроено еще, ибо еще с этим не разобрался):
/dev/disk/by-id/usb-WDC_WD32_00AAKS-00VYA0_WDC_WD3200_WD-WCARW0334300-0:0-part1 /media/WDSTORAGE ntfs-3g defaults,user 0 0

Кстати, раньше была такая же фигня(в 10.2), но с монтированием при загрузке, изначально файлы не отображались русские, стоит в консоли размонтировать-примонтировать, и все работает, так и не разобрался в чем дело :crazy:
Спасибо сказали:

insecto
Сообщения: 20
ОС: opensuse 10.2

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение insecto » 12.11.2007 19:50

Короче как делал я:
# Download and install FUSE (http://fuse.sourceforge.net)
# Download and install NTFS-3G(http://www.ntfs-3g.org)

Заходим в яст и маунтим /dev/hda2 как /mnt/winxp.

Потом в fstab лезем и там пишем что-то типо
/dev/hda2 /mnt/winxp ntfs-3g defaults 0 0

Все перегружаемся и радуемся жизни.

ЗЫ: такой способ не учитывает прав и групп, а так же, что обидно не показывает файлов с русскими буквами
( легко исправить вместо defaults пиши locale=ru_RU.utf8,defaults ) .
Возможно с локалью ошибся, так как писал по памяти. Если будут проблемы, могу более подробно расписать.
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 12.11.2007 21:10

так вот у меня как раз проблема, что не показывает русских файлов :(
причем после повторного монтирования из консоли показывает
Спасибо сказали:

Аватара пользователя
SLEDopit
Модератор
Сообщения: 4415
Статус: фанат консоли (=
ОС: GNU/Debian, RHEL

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение SLEDopit » 13.11.2007 00:38

insecto писал(а):
12.11.2007 19:50
Потом в fstab лезем и там пишем что-то типо
/dev/hda2 /mnt/winxp ntfs-3g defaults 0 0

это конечно здорово, но при таком условии при загрузке обязательно хард должен быть подсоединен (насколько я понял хард внешний, и он не обязательно должен быть у компа), иначе суся загрузиться тока в консольном режиме с возможностью входа исключительно рута. у меня такое было на следе 10,1 пришлось редактировать в консоле фстаб. как удалил эту запись стало все ок.
UNIX is basically a simple operating system, but you have to be a genius to understand the simplicity. © Dennis Ritchie
The more you believe you don't do mistakes, the more bugs are in your code.
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 13.11.2007 00:44

SLEDopit писал(а):
13.11.2007 00:38
insecto писал(а):
12.11.2007 19:50
Потом в fstab лезем и там пишем что-то типо
/dev/hda2 /mnt/winxp ntfs-3g defaults 0 0

это конечно здорово, но при таком условии при загрузке обязательно хард должен быть подсоединен (насколько я понял хард внешний, и он не обязательно должен быть у компа), иначе суся загрузиться тока в консольном режиме с возможностью входа исключительно рута. у меня такое было на следе 10,1 пришлось редактировать в консоле фстаб. как удалил эту запись стало все ок.

я тоже кстати об этом подумал :crazy:
А по решению проблемы кто нить может что нить сказать? :crazy:
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 14.11.2007 01:10

активнее пожалуйста, мне нужно найти решение до четверга :crazy:
Спасибо сказали:

Goodvin
Ведущий рубрики
Сообщения: 4332
Статус: ⚝⚠⚒⚑⚖☭☞☣☤&

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Goodvin » 14.11.2007 09:10

Bluetooth писал(а):
14.11.2007 01:10
активнее пожалуйста, мне нужно найти решение до четверга :crazy:
Не нужно создавать такие сообщения, это противоречит правилам и за это можно получить предупреждение.
Спасибо сказали:

blackdevil
Бывший модератор
Сообщения: 2751
Статус: Добровольный помощник
ОС: Ubuntu (lts)

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение blackdevil » 14.11.2007 16:36

так вот у меня как раз проблема, что не показывает русских файлов :(
причем после повторного монтирования из консоли показывает

Была такая фигня. Ключевая опция locale=ru_RU.utf8 если она отсутствует то как раз такое и получается. Почитать про это можно тут: http://ntfs-3g.org/support.html#locale
Простые решения для Ubuntu-подобных систем: смотрим тут
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 15.11.2007 02:14

blackdevil писал(а):
14.11.2007 16:36
так вот у меня как раз проблема, что не показывает русских файлов :(
причем после повторного монтирования из консоли показывает

Была такая фигня. Ключевая опция locale=ru_RU.utf8 если она отсутствует то как раз такое и получается. Почитать про это можно тут: http://ntfs-3g.org/support.html#locale

да, но при этом при монтировании из консоли с параметрами по умолчанию, русские файлы отображаются...
Но мне не интересно почему так, мне интересно как задать параметры локали для автомонтирующихся устройств?
Не нужно создавать такие сообщения, это противоречит правилам и за это можно получить предупреждение.

понял, больше не буду...
Спасибо сказали:

Аватара пользователя
MadDog
Бывший модератор
Сообщения: 2298
Статус: Добрый банщик

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение MadDog » 15.11.2007 07:57

Bluetooth писал(а):
15.11.2007 02:14
Но мне не интересно почему так, мне интересно как задать параметры локали для автомонтирующихся устройств?
И всё-таки, Вы так до сих пор и не показали свой /etc/fstab. Это великая тайна?
MadDog's Blog
Внимательно читать: Как правильно задавать вопросы
No fate but what we make
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 15.11.2007 10:00

MadDog писал(а):
15.11.2007 07:57
Bluetooth писал(а):
15.11.2007 02:14
Но мне не интересно почему так, мне интересно как задать параметры локали для автомонтирующихся устройств?
И всё-таки, Вы так до сих пор и не показали свой /etc/fstab. Это великая тайна?

В принципе я знаю как лечится отсуствие русских файлов, делал это заданием параметров в fstab, но в данном случае после добваления строчки в fstab у меня вылетае отшибка при попытке монтирования - пишет "error opening partition device"
вот строчка в fstab(само отображение русских файлов еще не настроено еще, ибо еще с этим не разобрался):

однако по просьбам трудящихся выкладываю фстаб полностью :)

Код: Выделить всё

/dev/disk/by-id/scsi-SATA_WDC_WD2500JS-00_WD-WCANK1017160-part1 /windows/            vfat       noatime,iocharset=utf8      0 0
/dev/sda2            /                    ext3       acl,user_xattr        1 1
/dev/sda5            /home2               ext3       user,acl,user_xattr,exec   1 2
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
/dev/fd0             /media/floppy        auto       user,sync,gid=users,umask=0002            0 0
/dev/sdc2            /oldSUSE             ext3       defaults              1 2
/dev/sdb5            /home                ext3       user,acl,user_xattr,exec 1 2
/dev/disk/by-id/scsi-SATA_WDC_WD3200AAKS-_WD-WCARW0300195-part1 swap                 swap       defaults              0 0
/dev/disk/by-id/usb-WDC_WD32_00AAKS-00VYA0_WDC_WD3200_WD-WCARW0334300-0:0-part1 /media/WDSTORAGE ntfs-3g defaults,user 0 0
Спасибо сказали:

Аватара пользователя
MadDog
Бывший модератор
Сообщения: 2298
Статус: Добрый банщик

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение MadDog » 15.11.2007 12:53

blackdevil писал(а):
14.11.2007 16:36
Ключевая опция locale=ru_RU.utf8
Добавьте в свой fstab только не то, что советовали, а locale=ru_RU.UTF-8

У меня дома с таким параметром всё прекрасно монтируется. Будут ошибки, полный текст ошибки сюда.
MadDog's Blog
Внимательно читать: Как правильно задавать вопросы
No fate but what we make
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 15.11.2007 16:23

Ну сделал так как вы сказали, но как я и думал, диск не примонтировался, пишет - нет доступа...

хм, и под рутом то же самое....

добавил параметр user, под рутом стал монтировать, а под юзером не хочет :(
Спасибо сказали:

blackdevil
Бывший модератор
Сообщения: 2751
Статус: Добровольный помощник
ОС: Ubuntu (lts)

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение blackdevil » 15.11.2007 22:41

вот мой fstab, все работает на ура!
andrew@DELL:~> cat /etc/fstab
/dev/sda5 / ext3 acl,user_xattr 1 1
/dev/sda7 /home ext3 defaults 1 2
/dev/sda6 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/sda2 /mnt/windows ntfs-3g rw,umask=0,locale=ru_RU.utf8 0 2
tmpfs /dev/shm tmpfs defaults 0 0
Простые решения для Ubuntu-подобных систем: смотрим тут
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 15.11.2007 23:57

не помогло, из-под рута монтируется, а из под юзера пишет "Error opening partition device: отказано в доступе"
Спасибо сказали:

Аватара пользователя
MadDog
Бывший модератор
Сообщения: 2298
Статус: Добрый банщик

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение MadDog » 16.11.2007 00:06

Bluetooth писал(а):
15.11.2007 23:57
не помогло, из-под рута монтируется, а из под юзера пишет "Error opening partition device: отказано в доступе"
Значит надо своего пользователя добавить в группу. В какую? Это надо уже пользователей Суси спрашивать.
А зачем из под пользователя монтировать? Вы же хотели чтобы на автомате и русскими буквами. Пользователя пускает в виндовый раздел?
MadDog's Blog
Внимательно читать: Как правильно задавать вопросы
No fate but what we make
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 17.11.2007 00:42

MadDog писал(а):
16.11.2007 00:06
Bluetooth писал(а):
15.11.2007 23:57
не помогло, из-под рута монтируется, а из под юзера пишет "Error opening partition device: отказано в доступе"
Значит надо своего пользователя добавить в группу. В какую? Это надо уже пользователей Суси спрашивать.
А зачем из под пользователя монтировать? Вы же хотели чтобы на автомате и русскими буквами. Пользователя пускает в виндовый раздел?

ну так он на автомате и не монтирует как раз...
Пускает
Спасибо сказали:

itroot
Сообщения: 18
ОС: opensuse 10.3

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение itroot » 17.11.2007 01:29

мой /etc/fstab - все работает.

Код: Выделить всё

/dev/disk/by-id/scsi-SATA_ST9100824A_5PL1DXZN-part7 /                    ext3       acl,user_xattr        1 1
/dev/disk/by-id/scsi-SATA_ST9100824A_5PL1DXZN-part6 /home                ext3       defaults              1 2
/dev/disk/by-id/scsi-SATA_ST9100824A_5PL1DXZN-part1 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/scsi-SATA_ST9100824A_5PL1DXZN-part5 swap                 swap       defaults              0 0
/dev/sdb1                                           /windows/D           ntfs-3g    force,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
#
Спасибо сказали:

Аватара пользователя
Bluetooth
Сообщения: 4395
Статус: Блюзовый
ОС: Debian Squeeze amd64

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Bluetooth » 17.11.2007 17:30

спасибо, изменил свой fstab по подобию, но проверить смогу толкьо когда притащат хард снова :)
Спасибо сказали:

Аватара пользователя
big
Сообщения: 38
ОС: Arch Current

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение big » 04.05.2008 08:45

так проблему решили?
Спасибо сказали:

Аватара пользователя
zwey
Сообщения: 161
ОС: OpenSuSE 11.1

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение zwey » 04.05.2008 09:40

а так делал?
Adding /sbin/mount.ntfs is more easier (hal-0.5.9.1 or later)

Just adding a mount.ntfs file makes the mount use ntfs-3g rather than the kernel ntfs

You can also make youself a nice little script to pass extra options to the mount command when mounting an NTFS fs. (i actually like the force command ;) ) /sbin/mount.ntfs.sh

#!/bin/bash
ntfs-3g "$@" -o locale=el_GR.utf8,force

Dont forget to make it excecutable:

chmod +x /sbin/mount.ntfs.sh

Now just linking it to mount.ntfs does the trick

ln -s /sbin/mount.ntfs.sh /sbin/mount.ntfs

Думаю соответствующую локаль вставишь.
У самого такая проблема, монтирую для rw внешние юсб винты в консоле вручную, но хотелось чтобы все это было автоматически. Сейчас самому проверить это нет возможности, мой внешний винт в fat, а знакомый принесет ntfs винт только на следующей неделе. Если получиться отпишитесь.
Designer for Windows 7 - Powered by OpenSuSE 11.1
Спасибо сказали:

Аватара пользователя
big
Сообщения: 38
ОС: Arch Current

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение big » 04.05.2008 09:48

а что, если убрать эту строчку из fstab:

Код: Выделить всё

/dev/sdb1  /windows/D ntfs-3g force,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0


и добавить в rc.local скрипт с условием "если винт подключен, то mount /dev/sdb1 /windows/D ntfs-3g force,users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0"?
Спасибо сказали:

KernelPanic
Бывший модератор
Сообщения: 2060
Статус: Brain Атаке
ОС: Debian squeeze/sid/exp

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение KernelPanic » 04.05.2008 10:33

big, это работать не будет хотя бы потому, что команда записана неправильно :)
zwey, не знаю, насколько это работоспособно.
Я делаю проще.
1) Добавляем правило для HAL.
В папке /etc/hal/fdi/policy создаем текстовый файлик 10-ntfs-usb.fdi следующего содержания:

Код: Выделить всё

<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
    <device>
        <match key="volume.fstype" string="ntfs">
            <match key="@block.storage_device:storage.hotpluggable" bool="true">
                <merge key="volume.fstype" type="string">ntfs-3g</merge>
                <merge key="volume.policy.mount_filesystem" type="string">ntfs-3g</merge>
            </match>
        </match>
    </device>
</deviceinfo>

Этот код был взят из Вики, довольно давно известен, после этого вставляемый USB-винт с ntfs разделом будет определяться как винт с разделом типа ntfs-3g, и, соответственно, пытаться использоватьь соотвествующий драйвер, а именно: файлик /sbin/mount.ntfs-3g (этот файлик, в свою очередь, являетяс лишь символической ссылкой на бинарник /usr/bin/ntfs-3g).

2) Заменяем ссылку /sbin/mount.ntfs-3g файлом с таким же именем со следующим скриптом:

Код: Выделить всё

#!/bin/bash

# Additional mounting options (cyrillic correction)
additional_options=",locale=ru_RU.UTF-8"

# Maximum parameters count
Num=0

# Use correction
use_correction=0

# Filling the array of input parameters
for input_param in $*
do
  let "Num++"    # Increment Num
  params[$Num]=$input_param
done

# Main checking cycle (check mount input parameters)
for ((i=1; i <= Num; i++))
do
  # Checking if Mounting Options specified
  if [ ${params[$i]} = "-o" ]; then
    let "i++"                         # go to the next parameter (mount options themself)
    let "use_correction = 1"                # need to use correction
    params[$i]=${params[$i]}"$additional_options"    # update mount options
  fi
done

if [ $use_correction -eq 1 ]; then
  # Filling new mount options
  parameters=''
  for (( i=1; i <= Num; i++ ))
  do
    if [ $i -eq $Num ]; then
      parameters=$parameters"${params[$i]}"
    else
      parameters=$parameters"${params[$i]} "
    fi
  done
  # mount
  /usr/bin/ntfs-3g $parameters
else
  /usr/bin/ntfs-3g $*
fi


Делаем его исполняемым и вперед :)
Спасибо сказали:

Аватара пользователя
zwey
Сообщения: 161
ОС: OpenSuSE 11.1

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение zwey » 04.05.2008 10:37

KernelPanic, подглядел это из генто вики, как вариант установки русской локали при автомонтировании. Сам не пробовал, так как не начем. Стоит попробовать твой способ.
Designer for Windows 7 - Powered by OpenSuSE 11.1
Спасибо сказали:

Аватара пользователя
big
Сообщения: 38
ОС: Arch Current

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение big » 04.05.2008 10:57

KernelPanic писал(а):
04.05.2008 10:33
big, это работать не будет хотя бы потому, что команда записана неправильно :)

на првильность и не претендовал, просто скопировал из постов выше... ;)
Спасибо сказали:

KernelPanic
Бывший модератор
Сообщения: 2060
Статус: Brain Атаке
ОС: Debian squeeze/sid/exp

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение KernelPanic » 04.05.2008 11:03

Это было даже не из генту, а из arch'а, я оттуда брал.
Если будут проблемы с монтированием, то сначала стоит убедиться в том, что бинарник /usr/bin/ntfs-3g именно там, если нет, то подправить скриптик в самом конце, куда нужно.
В начале скрипта можно выставить нужную локаль.

Если будут проблемы с монтированием/отмонтированием USB-HDD из под юзера, то нужно после присоединения диска, но ДО его монтирования, через konqueror (в KDE) сходить в system:/media и на появившемся имени устройства правой кнопкой мыши, далее зайти в параметры монтирования и УБРАТЬ галочку "mount as user" (монтировать от пользователя).

При любых последующих автомонтированиях этого же диска данный параметр сохранится и больше не надо его подправлять.

Короче для любого нового (вообще первый раз подключаешь когда) USB-HDD диска с ntfs выполнить тоже самое, если будут проблемы.

на првильность и не претендовал, просто скопировал из постов выше...

Надо все-таки man mount и почитать, там синтаксис отличается от fstab (для него можно посмотреть man fstab).
Спасибо сказали:

Raiden14
Сообщения: 1
ОС: openSuse 10.2

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Raiden14 » 04.05.2008 19:55

Я делал так:
1. Открываем файл /etc/fstab и для ntfs разделов меняем следующую информацию:
/dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
на /dev/hda1 /windows/C ntfs-3g silent,gid=100,uid=1001,umask=000,locale=ru_RU.utf8 0 0
2. Открываем yast2 - Система - Редактор для файлов /etc/sysconfig - System - Kernel - MODULES_LOADED_ON_BOOT и добавляем строчку fuse.
3. Перезагружаемся. ntfs-разделы должны быть подмонтированы на чтение/запись
Замечание. Linux при копировании файлов со своих разделов на ntfs пытается скопировать и права доступа, поэтому может выводить некритические ошибки
Спасибо сказали:

KernelPanic
Бывший модератор
Сообщения: 2060
Статус: Brain Атаке
ОС: Debian squeeze/sid/exp

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение KernelPanic » 04.05.2008 20:29

Raiden14
Тут немного не по тому вопросу, мы про USB-HDD с типом ФС ntfs.
Про статические диски и так понятно.
Спасибо сказали:

Аватара пользователя
zwey
Сообщения: 161
ОС: OpenSuSE 11.1

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение zwey » 06.05.2008 14:23

KernelPanic попробовал как ты сказал. Вот что стало получаться. Но ntfs раздел так и не монтируется.
Есть идеи куда копать?
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Designer for Windows 7 - Powered by OpenSuSE 11.1
Спасибо сказали:

Slimy
Сообщения: 1689
ОС: openSuSE 11.2 GM (GеMор едишн)

Re: Проблема с автомонтированием NTFS(драйвер ntfs-3g)

Сообщение Slimy » 06.05.2008 20:13

кстати да проблема эта не только в suse сегодня в мандриве столкнулся с ней. Чесно сказать были причины для паники когда не оказалось на флешке с ntfs каталога приэтом остальные были на месте. Перегрузился в оффтопик папка на месте. Прочитал тему и стало понятно что же случилось. Похоже на баг в драйвере.
Если уже ничего не помогает - прочти инструкцию.
sysinstall - гадость :)
ASUS A6q00Vm Pentium-M 1.7 GHz, 2Gb RAM, 160Gb HDD,
GeForce Go 7300 64Mb video
Спасибо сказали:

Вернуться в «SUSE»