запуск инета из другого пользователя (Session management error: Could not open network socket)

Обсуждение настройки и работы сервисов, резервирования, сетевых настроек и вопросов безопасности ОС.

Модераторы: SLEDopit, Модераторы разделов

Аватара пользователя
Sekta-N
Сообщения: 854
ОС: Зоопарк

запуск инета из другого пользователя

Сообщение Sekta-N »

Многие виндузятники любят говорить: вот система останется живой, а ваши документы полетят, что для вас важней. И у меня возникла идея, что можно отделить опасный браузер от основного пользователя и запускать из под другого, например:
su internet
# opera
но при запуске любого браузера выходит ошибка:
Session management error: Could not open network socket
К пользователю для начала добавил все группы и все равно в инет доступа не получил. :unsure:
Нет тут подписи и не будет.
Спасибо сказали:
Аватара пользователя
drBatty
Сообщения: 8735
Статус: GPG ID: 4DFBD1D6 дом горит, козёл не видит...
ОС: Slackware-current

Re: запуск инета из другого пользователя

Сообщение drBatty »

Sekta-N писал(а):
27.01.2008 15:04
И у меня возникла идея, что можно отделить опасный браузер от основного пользователя и запускать из под другого, например:


Может подойти с другого конца? Отделить документы от пользователя? Т.е. создать пользователя, и пусть он использует и изменяет документы(свои, атрибуты 644). А старый пусть лазает по сети. (новому инет-то не запустить :) )
http://emulek.blogspot.ru/ Windows Must Die
Учебник по sed зеркало в github

Скоро придёт
Осень
Спасибо сказали:
Аватара пользователя
Sekta-N
Сообщения: 854
ОС: Зоопарк

Re: запуск инета из другого пользователя

Сообщение Sekta-N »

То есть предлагаете делать так:
su olduser
# digikam
?
Тоже вариант.
И все-таки вопрос - почему нет доступа через select user? Пользователя от инета я могу заблокировать и через iptables - просто запретить использовать ppp0.
Нет тут подписи и не будет.
Спасибо сказали:
Аватара пользователя
drBatty
Сообщения: 8735
Статус: GPG ID: 4DFBD1D6 дом горит, козёл не видит...
ОС: Slackware-current

Re: запуск инета из другого пользователя

Сообщение drBatty »

Sekta-N писал(а):
27.01.2008 17:19
И все-таки вопрос - почему нет доступа через select user? Пользователя от инета я могу заблокировать и через iptables - просто запретить использовать ppp0.

А как вы проверяли наличие инета? Уж не ping ли? У меня он и под простым юзером не работает. А вот, например
su user
ftp имя_сервера
работает
http://emulek.blogspot.ru/ Windows Must Die
Учебник по sed зеркало в github

Скоро придёт
Осень
Спасибо сказали:
Аватара пользователя
Sekta-N
Сообщения: 854
ОС: Зоопарк

Re: запуск инета из другого пользователя

Сообщение Sekta-N »

Я же говорю веббраузерами проверял, а пинг у меня и ис под простого пользователя работает.
я же пишу выходит ошибка Session management error: Could not open network socket
Нет тут подписи и не будет.
Спасибо сказали: