Как настроить работу 1С на два сетевых интерфейса

Обсуждение настройки и работы сервисов, резервирования, сетевых настроек и вопросов безопасности ОС.

Модераторы: SLEDopit, Модераторы разделов

sinjevla
Сообщения: 121

Как настроить работу 1С на два сетевых интерфейса

Сообщение sinjevla »

Подключил две сети к серваку на Red Hat ES 5 eth0 eth1 c ip 172.11.101.XXX и 192.168.0.ХХХ настроил sambu компьютеры на винде видят сервак как с одной так и из другой сети. Сканирую nmap'ом показывает что открыты порты как в eth0 так и в eth1 одни и теже, но на подключаемой сети eth1 1С не работает хотя порты открыты 1540;1541;5432 первые 2 для 1С второй для postgresql. На eth0 все работало еще до подключения eth1 и сейчас работает, а вот как настроить на 1С на eth1. Может кто-то подскажет в чем причина
Спасибо сказали:
Аватара пользователя
newsrc
Сообщения: 314
ОС: Slackware

Re: Как настроить работу 1С на два сетевых интерфейса

Сообщение newsrc »

1. Что значит "1С не работает"? Не запускается программа сама, не верен путь к базам или что там ещё может быть...
2. 1С стоит на виндовозном компе в сети 192.168.0.ХХХ и базы берет с самбового сервера?
3. Покажите ifconfig и route -n
4. firewall'ы какие может включены???
5. #telnet server 1540...... попробуйте
Система -- это совокупность элементов и связей, дающая новые свойства, не присущие ни одному из элементов и ни одной из связей.
Спасибо сказали:
sinjevla
Сообщения: 121

Re: Как настроить работу 1С на два сетевых интерфейса

Сообщение sinjevla »

1C серверный вариант стоит на Red Hat ES 5 а клиенты на ХР. Все работает на eth0 c ip 172.11.101.XXX, я подключил еще одну сеть eth1 c ip 192.168.0.ХХХ при вкл. 1С мне выдает ошибку :

Ошибка при выполнении операции с информационной базой
server_addr=tcp://EvrHatSer:1562 descr=Ошибка сетевого доступа к серверу
(Windows Socrets -10060(0x0000274C). Попытка установки соединения была безуспешкной, т. к. от другого компьютера за требуемое время не получен нужный отклик, или было разорвано уже установленное соединение из-за неверного отклика уже подключенного компьютера.
Line=576 file=.\src\DataExchangeTcpClientlmpl.cpp

Про сканировании выдает
# nmap -sS 172.11.101.XXX
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-08-25 16:38 EEST
Interesting ports on 172.11.101.XXX
Not shown: 1670 closed ports
PORT STATE SERVICE
22/tcp open ssh
111/tcp open rpcbind
139/tcp open netbios-ssn
445/tcp open microsoft-ds
847/tcp open unknown
901/tcp open samba-swat
1540/tcp open rds
1541/tcp open rds2
5432/tcp open postgres
5900/tcp open vnc
Nmap finished: 1 IP address (1 host up) scanned in 13.056 seconds

# nmap -sS 192.168.0.XXX
Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2008-08-25 16:44 EEST
Interesting ports on 192.168.0.XXX:
Not shown: 1670 closed ports
PORT STATE SERVICE
22/tcp open ssh
111/tcp open rpcbind
139/tcp open netbios-ssn
445/tcp open microsoft-ds
847/tcp open unknown
901/tcp open samba-swat
1540/tcp open rds
1541/tcp open rds2
5432/tcp open postgres
5900/tcp open vnc
Nmap finished: 1 IP address (1 host up) scanned in 13.057 seconds

ifconfig и route –n показывает следующее
# ifconfig
eth0 Link encap:Ethernet HWaddr 00:15:17:
inet addr:172.11.101.XXX Bcast:172.11.101.255 Mask:255.255.255.0
inet6 addr: fe80::215:17ff:fe4c:5b1c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6697492 errors:0 dropped:0 overruns:0 frame:0
TX packets:13427396 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:2110552292 (1.9 GiB) TX bytes:2108852665 (1.9 GiB)
Base address:0x2020 Memory:f8820000-f8840000

eth1 Link encap:Ethernet HWaddr 00:15:17:
inet addr:192.168.0.XXX Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::215:17ff:fe4c:5b1d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2913800 errors:0 dropped:730 overruns:0 frame:0
TX packets:99403 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:821815584 (783.7 MiB) TX bytes:14367013 (13.7 MiB)
Base address:0x2000 Memory:f8800000-f8820000

# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
172.11.101.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth1

А telnet server 1540 выдает
# telnet server 1540
server/1540: Temporary failure in name resolution

firewall вообще выключил на время настроикй

как правильно настроить чтоб 1С работала и на eth1
Спасибо сказали:
Аватара пользователя
Kataklysm
Сообщения: 280
ОС: Linux Suse 10.2-10.3 Sles-10.1

Re: Как настроить работу 1С на два сетевых интерфейса

Сообщение Kataklysm »

"Перекидку" адреса сделай и не мучайся.
P.s. iptables или rinetd
Спасибо сказали:
Аватара пользователя
newsrc
Сообщения: 314
ОС: Slackware

Re: Как настроить работу 1С на два сетевых интерфейса

Сообщение newsrc »

Kataklysm писал(а): ↑
25.08.2008 20:21
"Перекидку" адреса сделай и не мучайся.
P.s. iptables или rinetd

Гениальный ответ. sinjevla, скажите спасибо Kataklysm, он вам так помог..........
А если по делу: посмотрите видят ли компы, которые в сети 192.168.0.ХХХ в сетевом окружении самбовые ресурсы, можно с помощью FAR'a Alt+F1 > сеть......
На счет telnet не уверен - должен или нет он коннектиться, попробуйте из сети 172.11.101.XXX посмотреть сетевое окружение и telnet'ом до сервера достучаться по нужным портам.

И ещё: отброшенные входящие пакеты у вас на интерфейсе eth1:

Код: Выделить всё

 RX packets:2913800 errors:0 dropped:730 overruns:0 frame:0
Система -- это совокупность элементов и связей, дающая новые свойства, не присущие ни одному из элементов и ни одной из связей.
Спасибо сказали:
Аватара пользователя
Kataklysm
Сообщения: 280
ОС: Linux Suse 10.2-10.3 Sles-10.1

Re: Как настроить работу 1С на два сетевых интерфейса

Сообщение Kataklysm »

cent64 писал(а): ↑
25.08.2008 22:02
Kataklysm писал(а): ↑
25.08.2008 20:21
"Перекидку" адреса сделай и не мучайся.
P.s. iptables или rinetd

Гениальный ответ. sinjevla, скажите спасибо Kataklysm, он вам так помог..........
А если по делу: посмотрите видят ли компы, которые в сети 192.168.0.ХХХ в сетевом окружении самбовые ресурсы, можно с помощью FAR'a Alt+F1 > сеть......
На счет telnet не уверен - должен или нет он коннектиться, попробуйте из сети 172.11.101.XXX посмотреть сетевое окружение и telnet'ом до сервера достучаться по нужным портам.

И ещё: отброшенные входящие пакеты у вас на интерфейсе eth1:

Код: Выделить всё

 RX packets:2913800 errors:0 dropped:730 overruns:0 frame:0


А ты сам подумай для начала...я как не пытался пустить 1С на две сетевухи, так оно и не получилось,ибо сам незнаю почему не хочет работать сразу по двум сетевухам. Из-за этого я у себя и сделал перекидку порта. При этом сам знаю, что идиотизм, но иначе никак...
P.S. cent64, так что перед тем как наезжать сами попробуйте.
Спасибо сказали:
sinjevla
Сообщения: 121

Re: Как настроить работу 1С на два сетевых интерфейса

Сообщение sinjevla »

Ребята много информации, iptables там есть над чем голову поломать
Насчет samba так она уменя настроена и компы из разных сетей видят друг друга а вот 1С не как.
"Перекидку" адреса сделать но как пока не знаю
Короче долбим :rolleyes:
Спасибо сказали: