Postfix+dovecot
Модераторы: SLEDopit, Модераторы разделов
-
Demolitionman
- Сообщения: 78
Postfix+dovecot
вобщем не знаю что с этим делать, но старался настроить чтобы постфикс клал локальную почту довекоду, что бы тот в свою очередь направлял эти письма локальным пользователям, вобщем все работает но только по отдельности
вот такой лог
Sep 10 17:00:04 ie postfix/smtpd[3617]: disconnect from unknown[192.168.112.1]
Sep 10 17:00:04 ie postfix/pipe[3614]: 1F6F6CEEAD: to=<saitov@ie.mail.kz>, relay=dovecot, delay=0.2, delays=0.15/0/0/0.05, dsn=4.3.0, status=deferred (temporary failure. Command output: Can't open log file /var/log/dovecot.info: Permission denied )
права давал все которые только можно 777 видимо постфикс пишет в один файл с довекот
вот такой лог
Sep 10 17:00:04 ie postfix/smtpd[3617]: disconnect from unknown[192.168.112.1]
Sep 10 17:00:04 ie postfix/pipe[3614]: 1F6F6CEEAD: to=<saitov@ie.mail.kz>, relay=dovecot, delay=0.2, delays=0.15/0/0/0.05, dsn=4.3.0, status=deferred (temporary failure. Command output: Can't open log file /var/log/dovecot.info: Permission denied )
права давал все которые только можно 777 видимо постфикс пишет в один файл с довекот
-
kosteel
- Сообщения: 330
- Статус: Root Lamer
- ОС: Debian GNU/Linux 5.02 amd64
Re: Postfix+dovecot
postfix пишет в /var/log/mail.log
проверте параметр relay_host
в приведенном логе постфикс говорит что relay_host=dovecot - это вы зачем сделали? Уберите оттуда довекот и поставте "none" или "local" у вас ведь локальные пользователи
проверте параметр relay_host
localhost
shell# postconf relay_host
в приведенном логе постфикс говорит что relay_host=dovecot - это вы зачем сделали? Уберите оттуда довекот и поставте "none" или "local" у вас ведь локальные пользователи
Ничто не вечно под рутом
-
Demolitionman
- Сообщения: 78
Re: Postfix+dovecot
kosteel писал(а): ↑11.09.2009 15:20postfix пишет в /var/log/mail.log
проверте параметр relay_host
localhost
shell# postconf relay_host
в приведенном логе постфикс говорит что relay_host=dovecot - это вы зачем сделали? Уберите оттуда довекот и поставте "none" или "local" у вас ведь локальные пользователи
вот мои конфы/
main.cf
Код: Выделить всё
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailbox_transport = dovecot
manpage_directory = /usr/share/man
mydomain = ie.mail.kz
myhostname = ie.mail.kz
mynetworks = 192.168.112.0/24, 127.0.0.0/8
mynetworks_style = 192.168.112.0/24
myorigin = infraenergo.kz
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
relay_domains = infraenergo.kz
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdropу меня указан mailbox_transport = dovecot поэтому он и показывает что релей довекот,
dovecot.conf
Код: Выделить всё
base_dir = /var/run/dovecot/
protocols = pop3
protocol pop3 {
listen = *:110
}
info_log_path = /var/log/dovecot.info
ssl_disable = yes
mail_location = mbox:/var/mail/%d/%n:INDEX=/var/mail/%d/%n
mail_debug = yes
first_valid_uid = 5000
last_valid_uid = 5000
first_valid_gid = 5000
last_valid_gid = 5000
auth_verbose = yes
auth_debug = yes
auth default {
mechanisms = plain login digest-md5
passdb passwd-file {
args = /etc/dovecotpasswd
}
userdb passwd-file {
args = /etc/dovecotusers
}
socket listen {
master {
path = /var/run/dovecot/auth-master
mode = 0600
# Default user/group is the one who started dovecot-auth (root)
user = vmail
group = vmail
}
client {
path = /var/spool/postfix/private/dovecot-smtp-auth
mode = 0660
user = postfix
group = postfix
}
}
}
disable_plaintext_auth = nomaster.cf
Код: Выделить всё
smtp inet n - n - - smtpd
pickup fifo n - n 60 1 pickup
cleanup unix n - n - 0 cleanup
qmgr fifo n - n 300 1 qmgr
tlsmgr unix - - n 1000? 1 tlsmgr
rewrite unix - - n - - trivial-rewrite
bounce unix - - n - 0 bounce
defer unix - - n - 0 bounce
trace unix - - n - 0 bounce
verify unix - - n - 1 verify
flush unix n - n 1000? 0 flush
proxymap unix - - n - - proxymap
smtp unix - - n - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - n - - smtp
-o fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - n - - showq
error unix - - n - - error
discard unix - - n - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - n - - lmtp
anvil unix - - n - 1 anvil
scache unix - - n - 1 scache
dovecot unix - n n - - pipe
flags=DRhu user=vmail:vmail argv=/usr/libexec/dovecot/deliver -d ${recipient}по идее постфикс должен отдавать локальные письма довекоту ну а тот уже в свою очередь локальным пользователям которых я завел в довекоде/
я гдето читал про эту ошибку Command output: Can't open log file /var/log/dovecot.info: Permission denied
там говорили пускать довекод и постфикс через syslog а как это сделать ничего не сказано
вообще мне надо просто чтобы письма локальных пользователей которые шлют на локальный домен ie.mail.kz постфикс клал в ящики довекода/
а уж если во внешку письмо то оно уходило через релей infraenergo.kz вот и все
про будущие геморы с фетчмаил я пока что не думаю хотя он тоже должен будет отдавать письма довекоду
-
diesel
- Бывший модератор
- Сообщения: 5989
- ОС: OS X, openSuSE, ROSA, Debian
Re: Postfix+dovecot
i Уведомление от модератора go to "администрирование для начинающих"
-
skeletor
- Сообщения: 1224
Re: Postfix+dovecot
Обязательно ли писать логи от dovecot'a в отдельный файл? Сделайте так:
Код: Выделить всё
log_path = /var/log/maillog-
kosteel
- Сообщения: 330
- Статус: Root Lamer
- ОС: Debian GNU/Linux 5.02 amd64
Re: Postfix+dovecot
Demolitionman писал(а): ↑14.09.2009 12:23по идее постфикс должен отдавать локальные письма довекоту ну а тот уже в свою очередь локальным пользователям которых я завел в довекоде/
я гдето читал про эту ошибку Command output: Can't open log file /var/log/dovecot.info: Permission denied
там говорили пускать довекод и постфикс через syslog а как это сделать ничего не сказано
вообще мне надо просто чтобы письма локальных пользователей которые шлют на локальный домен ie.mail.kz постфикс клал в ящики довекода/
а уж если во внешку письмо то оно уходило через релей infraenergo.kz вот и все
про будущие геморы с фетчмаил я пока что не думаю хотя он тоже должен будет отдавать письма довекоду
Не совсем так, постфикс ничего не отдает довекоту, происходит следующее: по сути postfix и dovecot предоставляют специальное соединение по протоколу telnet по умолчанию на 25 и 110 порт соотвественно, постфикс отвечает за то, чтобы получить письмо от отправителя и положить его в почтовый ящик получателя, а довекот отдает вошедшее письмо получателю и единственное чем связаны между собой постфикс и довекот так это параметр mail_spool_directory в постфикс и параметр mailbox_location в довекот, к стати у вас в конфиге эти параметры не фигурируют вовсе. Не надо указывать довекот в транспорте, оставьте этот парамерт пустым ведь вы используете postfix в качаестве MTA (доставщика почты) в этапе доставки почты dovecot не принимает никакого участия. После чего из командной строки:
localhost
shell# telnet <mail_server_name> 25
HELO <имя отправителя>
mail from: <адрес отправителя>
rcpt to: <адрес получателя>
data
<текст письма>
.
quit
обратите внимание что после команды "data" начнется ввод текста письма, окончание ввода заканчивается <CR><LF>.<CR><LF> (то есть нужно нажать энтер затем набрать точку и снова энтер) после этого писмо будет отправлено.
Тепер идем к получателю и смотрим пришло ли письмо:
localhost
shell# telnet <mail_server_name> 110
user <имя получателя>
pass <пароль>
stat
+OK 1 496
quit
вот это вот "+OK 1 496" означет что в почтовом ящике есть 1 письмо размером 496кб, значит все в порядке, можете пользоваться. Если будет +OK 0 0 значит по каким-то причинам писмо не дошло. По остальным вопросам добро пожаловать в /var/log/mail.log
Ничто не вечно под рутом
-
Demolitionman
- Сообщения: 78
Re: Postfix+dovecot
kosteel писал(а): ↑14.09.2009 13:27Demolitionman писал(а): ↑14.09.2009 12:23по идее постфикс должен отдавать локальные письма довекоту ну а тот уже в свою очередь локальным пользователям которых я завел в довекоде/
я гдето читал про эту ошибку Command output: Can't open log file /var/log/dovecot.info: Permission denied
там говорили пускать довекод и постфикс через syslog а как это сделать ничего не сказано
вообще мне надо просто чтобы письма локальных пользователей которые шлют на локальный домен ie.mail.kz постфикс клал в ящики довекода/
а уж если во внешку письмо то оно уходило через релей infraenergo.kz вот и все
про будущие геморы с фетчмаил я пока что не думаю хотя он тоже должен будет отдавать письма довекоду
Не совсем так, постфикс ничего не отдает довекоту, происходит следующее: по сути postfix и dovecot предоставляют специальное соединение по протоколу telnet по умолчанию на 25 и 110 порт соотвественно, постфикс отвечает за то, чтобы получить письмо от отправителя и положить его в почтовый ящик получателя, а довекот отдает вошедшее письмо получателю и единственное чем связаны между собой постфикс и довекот так это параметр mail_spool_directory в постфикс и параметр mailbox_location в довекот, к стати у вас в конфиге эти параметры не фигурируют вовсе. Не надо указывать довекот в транспорте, оставьте этот парамерт пустым ведь вы используете postfix в качаестве MTA (доставщика почты) в этапе доставки почты dovecot не принимает никакого участия. После чего из командной строки:
localhost
shell# telnet <mail_server_name> 25 HELO <имя отправителя> mail from: <адрес отправителя> rcpt to: <адрес получателя> data <текст письма> . quit
обратите внимание что после команды "data" начнется ввод текста письма, окончание ввода заканчивается <CR><LF>.<CR><LF> (то есть нужно нажать энтер затем набрать точку и снова энтер) после этого писмо будет отправлено.
Тепер идем к получателю и смотрим пришло ли письмо:
localhost
shell# telnet <mail_server_name> 110 user <имя получателя> pass <пароль> stat +OK 1 496 quit
вот это вот "+OK 1 496" означет что в почтовом ящике есть 1 письмо размером 496кб, значит все в порядке, можете пользоваться. Если будет +OK 0 0 значит по каким-то причинам писмо не дошло. По остальным вопросам добро пожаловать в /var/log/mail.log
вобщем добавил я кое что и кое что убрал
конфи постфикса
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
mail_owner = postfix
mail_spool_directory = /var/mail
manpage_directory = /usr/share/man
myhostname = ie.mail.kz
mynetworks = 192.168.112.0/24, 127.0.0.0/8
mynetworks_style = 192.168.112.0/24
myorigin = infraenergo.kz
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
relay_domains = infraenergo.kz
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
вот только при отправке письма в логах
Sep 15 14:04:55 ie postfix/postfix-script: starting the Postfix mail system
Sep 15 14:04:55 ie postfix/master[10661]: daemon started -- version 2.3.3, configuration /etc/postfix
Sep 15 14:05:08 ie postfix/smtpd[10664]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 15 14:05:08 ie postfix/smtpd[10664]: connect from unknown[192.168.112.1]
Sep 15 14:05:08 ie postfix/smtpd[10664]: D0F68CEE48: client=unknown[192.168.112.1]
Sep 15 14:05:08 ie postfix/cleanup[10667]: D0F68CEE48: message-id=<005301ca35da$ef033d30$16cecc58@InternetServer>
Sep 15 14:05:08 ie postfix/qmgr[10663]: D0F68CEE48: from=<saitov@ie.mail.kz>, size=1345, nrcpt=1 (queue active)
Sep 15 14:05:08 ie postfix/smtpd[10664]: disconnect from unknown[192.168.112.1]
Sep 15 14:05:08 ie postfix/local[10668]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Sep 15 14:05:08 ie postfix/local[10668]: D0F68CEE48: to=<saitov@ie.mail.kz>, relay=local, delay=0.15, delays=0.07/0.01/0/0.07, dsn=2.0.0, status=sent (delivered to mailbox)
Sep 15 14:05:09 ie postfix/qmgr[10663]: D0F68CEE48: removed
захожу значи в var/mail там лежит письмо которое я послал в файле saitov
теперь ни как не могу научить довекот заберать это письмо в конфе довекода вот такая строчка
mail_location = mbox:/var/mail/%d
переменную %d в конце менял, в основном создается папка ie.mail.kz в директории var/mail в этой папке лежит файл inbox вот вроде от туда он и хочет заберать почту, вобщем как их свести в одну точку
еще такая проблема возникла, вроде создаю вертуальных пользователей и знакомый у меня их тоже во фряхе создавал именно для постфикса я создавал через сасл ну ни как постфикс не хочет их видить пока реального пользователя в системе не заведешь нифига не авторизирует
-
skeletor
- Сообщения: 1224
Re: Postfix+dovecot
Да потому что %d отвечает за домен!!!! Хотите, что бы был юзер - пишите %n.
-
Demolitionman
- Сообщения: 78
Re: Postfix+dovecot
Sep 15 14:37:00 ie dovecot: POP3(saitov@ie.mail.kz): mbox root directory can't be a file: /var/mail/saitov (http://wiki.dovecot.org/MailLocation/Mbox)
Sep 15 14:37:00 ie dovecot: POP3(saitov@ie.mail.kz): mkdir_parents(/var/mail/saitov/.imap/INBOX) failed: Not a directory
Sep 15 14:37:00 ie dovecot: POP3(saitov@ie.mail.kz): stat() failed with mbox file /var/mail/saitov/inbox: Not a directory
Sep 15 14:37:00 ie dovecot: POP3(saitov@ie.mail.kz): Couldn't init INBOX: Can't sync mailbox: Messages keep getting expunged
Sep 15 14:37:24 ie dovecot: Logins with UID 5001 (user saitov) not permitted (see first_valid_uid in config file)
Sep 15 14:37:32 ie dovecot: POP3(saitov@ie.mail.kz): mbox root directory can't be a file: /var/mail/saitov (http://wiki.dovecot.org/MailLocation/Mbox)
Sep 15 14:37:32 ie dovecot: POP3(saitov@ie.mail.kz): mkdir_parents(/var/mail/saitov/.imap/INBOX) failed: Not a directory
Sep 15 14:37:32 ie dovecot: POP3(saitov@ie.mail.kz): stat() failed with mbox file /var/mail/saitov/inbox: Not a directory
Sep 15 14:37:32 ie dovecot: POP3(saitov@ie.mail.kz): Couldn't init INBOX: Can't sync mailbox: Messages keep getting expunged
вот что пишет
-
skeletor
- Сообщения: 1224
Re: Postfix+dovecot
Ну конечно, если всё лепить в кучу, то так и будет. Пробуй так:
Код: Выделить всё
mail_location = mbox:/var/mail/%n:INBOX=/var/mail/%d/%u-
Demolitionman
- Сообщения: 78
Re: Postfix+dovecot
skeletor писал(а): ↑15.09.2009 12:45Ну конечно, если всё лепить в кучу, то так и будет. Пробуй так:
Код: Выделить всё
mail_location = mbox:/var/mail/%n:INBOX=/var/mail/%d/%u
с логами разобрался, проблему устранил, просто удалил письмо с дериктории var/maii/ фаил saitov это письмо которое постфикс ложит, он его файлом ложит в вар/маил
а довекот пытается там директорию создать var/mail/saitov/inbox вот и не получалось у него так как там уже был файл saitov
как довекоду дать понять что этот файл и есть почта которую надо стянуть? или чтото в постфиксе переделать надо? можно ваши конфы? или ссылку на РАбочие настройки Dovecot+postfix+fenchmail с виртуальными пользователями
у мну редхат
-
skeletor
- Сообщения: 1224
Re: Postfix+dovecot
Ну во-первых, у вас явно указано в postfix
что означает, что postfix вообще никакого отношения не имеет к вашим ящикам (оно так и должно быть, ведь его задача принял-отправил). Во-вторых, вам действительно необходимо юзать mbox-формат? Неужели maildir не подходит? И в третьих, у меня на сайте есть несколько статей на эту тему, правда для FreeBSD, но конфиги-то они и в RH конфиги. Так что, заходи http://skeletor.ho.ua в раздел "Почтовые системы" и выбирай, что нужно.
Код: Выделить всё
mailbox_transport = dovecotчто означает, что postfix вообще никакого отношения не имеет к вашим ящикам (оно так и должно быть, ведь его задача принял-отправил). Во-вторых, вам действительно необходимо юзать mbox-формат? Неужели maildir не подходит? И в третьих, у меня на сайте есть несколько статей на эту тему, правда для FreeBSD, но конфиги-то они и в RH конфиги. Так что, заходи http://skeletor.ho.ua в раздел "Почтовые системы" и выбирай, что нужно.
-
Demolitionman
- Сообщения: 78
Re: Postfix+dovecot
kosteel писал(а): ↑14.09.2009 13:27Demolitionman писал(а): ↑14.09.2009 12:23по идее постфикс должен отдавать локальные письма довекоту ну а тот уже в свою очередь локальным пользователям которых я завел в довекоде/
я гдето читал про эту ошибку Command output: Can't open log file /var/log/dovecot.info: Permission denied
там говорили пускать довекод и постфикс через syslog а как это сделать ничего не сказано
вообще мне надо просто чтобы письма локальных пользователей которые шлют на локальный домен ie.mail.kz постфикс клал в ящики довекода/
а уж если во внешку письмо то оно уходило через релей infraenergo.kz вот и все
про будущие геморы с фетчмаил я пока что не думаю хотя он тоже должен будет отдавать письма довекоду
Не совсем так, постфикс ничего не отдает довекоту, происходит следующее: по сути postfix и dovecot предоставляют специальное соединение по протоколу telnet по умолчанию на 25 и 110 порт соотвественно, постфикс отвечает за то, чтобы получить письмо от отправителя и положить его в почтовый ящик получателя, а довекот отдает вошедшее письмо получателю и единственное чем связаны между собой постфикс и довекот так это параметр mail_spool_directory в постфикс и параметр mailbox_location в довекот, к стати у вас в конфиге эти параметры не фигурируют вовсе. Не надо указывать довекот в транспорте, оставьте этот парамерт пустым ведь вы используете postfix в качаестве MTA (доставщика почты) в этапе доставки почты dovecot не принимает никакого участия. После чего из командной строки:
localhost
shell# telnet <mail_server_name> 25 HELO <имя отправителя> mail from: <адрес отправителя> rcpt to: <адрес получателя> data <текст письма> . quit
обратите внимание что после команды "data" начнется ввод текста письма, окончание ввода заканчивается <CR><LF>.<CR><LF> (то есть нужно нажать энтер затем набрать точку и снова энтер) после этого писмо будет отправлено.
Тепер идем к получателю и смотрим пришло ли письмо:
localhost
shell# telnet <mail_server_name> 110 user <имя получателя> pass <пароль> stat +OK 1 496 quit
вот это вот "+OK 1 496" означет что в почтовом ящике есть 1 письмо размером 496кб, значит все в порядке, можете пользоваться. Если будет +OK 0 0 значит по каким-то причинам писмо не дошло. По остальным вопросам добро пожаловать в /var/log/mail.log
все получилось все работает, но только локально, во внешку пользователи не могут переслать письмо, в роли транспорта локальных писем выступает довекот для пересылки писем во внешку использую параметр relayhost = infraenergo.kz вот лог и конф
Sep 23 13:01:51 mail postfix/smtp[28057]: AE301642B1: to=<vsemrespekt@mail.ru>, relay=infraenergo.kz[92.46.175.16]:25, delay=22, delays=20/0.06/2.3/0.23, dsn=5.0.0, status=bounced (host infraenergo.kz[92.46.175.16] said: 550-Verification failed for <saitov@ie.mail.kz> 550-The mail server could not deliver mail to saitov@ie.mail.kz. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries. 550 Sender verify failed (in reply to RCPT TO command))
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
biff = no
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
disable_dns_lookups = yes
html_directory = /usr/share/doc/packages/postfix-doc/html
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mailbox_transport = dovecot
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
mydestination = ie.mail.kz infraenergo.kz
myhostname = mail.ie.mail.kz
mynetworks = 192.168.112.0/24, 127.0.0.0/8, 192.168.100.0/24
myorigin = infraenergo.kz
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix-doc/README_FILES
relay_domains = $mydestination
relayhost = [infraenergo.kz]
sample_directory = /usr/share/doc/packages/postfix-doc/samples
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =
smtpd_banner = $myhostname ESMTP $mail_name
unknown_local_recipient_reject_code = 550
в sasl_passwd
infraenergo.kz login:pass
вроде все правельно сделал
раньше когда настраивал пересылку во внешку без локалки вроде все работало, а вот теперь почемуто нет, мож забыл какой параметр указать
сразу предупреждаю домена ie.mail.kz не существует. когда письма со старого почтаря идут во внешку они доходят до адресата с таким адресом infraenergo@infraenergo.kz
то есть при отмсылке вместо user@ie.mail.kz должно подставляться infraenergo@infraenergo.kz
-
kosteel
- Сообщения: 330
- Статус: Root Lamer
- ОС: Debian GNU/Linux 5.02 amd64
Re: Postfix+dovecot
то есть все письма от локальных пользователей отправленные во вне должны идти через 1 единственный электронный адрес? Правильно я понял? По идее это можно сделать с помощью алиасов на сервере infraenergo.kz. Хотя всетаки мне кажеться что должно быть как-то так: вы отправляете письмо, если в постфиксе не существует домена (нпаример письмо на @mail.ru и локально в постфиксе такого домена нет) то в игру вступает relayhost которому постфикс пересылает ваше письмо, а оттуда письмо уже летит во внешнюю сеть и никакой подстановки имен.
Судя по ругани в логах ваш infraenergo знать не знает никого ie.mail.kz, на нем нуно прописать этот домен (хотя я могу и врать).
Судя по ругани в логах ваш infraenergo знать не знает никого ie.mail.kz, на нем нуно прописать этот домен (хотя я могу и врать).
Ничто не вечно под рутом
-
Demolitionman
- Сообщения: 78
Re: Postfix+dovecot
kosteel писал(а): ↑23.09.2009 14:34Хотя всетаки мне кажеться что должно быть как-то так: вы отправляете письмо, если в постфиксе не существует домена (нпаример письмо на @mail.ru и локально в постфиксе такого домена нет) то в игру вступает relayhost которому постфикс пересылает ваше письмо, а оттуда письмо уже летит во внешнюю сеть и никакой подстановки имен.
Судя по ругани в логах ваш infraenergo знать не знает никого ie.mail.kz, на нем нуно прописать этот домен (хотя я могу и врать).
все именно так и должно быть, только вот мой релей infraenergo.kz не принемает письма от ie.mail.kz потому что этого домена не существует, он строго локальный для внутренней сети. как я могу пересылать письма через своего хостера Infraenergo.kz ели я знаю логин и пароль для доступа?
Как вобщем менять имя локального домена на имя реального? иначе письмо не уйдет
-
kosteel
- Сообщения: 330
- Статус: Root Lamer
- ОС: Debian GNU/Linux 5.02 amd64
Re: Postfix+dovecot
Тэкс... тут похоже нужно вот что сделать: в /etc/aliaces прописать что-то вроде
и соотвественно скомандовать newaliaces.
Только тут осторожнее, после этого все письма отправленные на @ie.mail.kz будут перенаправляться на infraenergo.kz в общем по моему тут надо как-то алиасами разруливать.
Код: Выделить всё
@ie.mail.kz: @infraenergo.kzи соотвественно скомандовать newaliaces.
Только тут осторожнее, после этого все письма отправленные на @ie.mail.kz будут перенаправляться на infraenergo.kz в общем по моему тут надо как-то алиасами разруливать.
Ничто не вечно под рутом