не работает печать (ошибка при старте cupsd)

Обсуждение настройки и работы сервисов, резервирования, сетевых настроек и вопросов безопасности ОС.

Модераторы: SLEDopit, Модераторы разделов

Najar
Сообщения: 6
ОС: Ubuntu 8.04

не работает печать

Сообщение Najar »

собственно проблема в том что принтер не печатает.
страница http://localhost:631 не открывается.
при старте cupsd в логе /var/log/cups/error_log:

Код:

I [24/Jul/2008:00:32:12 +0700] Loaded configuration file "/etc/cups/cupsd.conf" N [24/Jul/2008:00:32:12 +0700] Group and SystemGroup cannot use the same groups! I [24/Jul/2008:00:32:12 +0700] Resetting Group to "root"... I [24/Jul/2008:00:32:12 +0700] Configured for up to 100 clients. I [24/Jul/2008:00:32:12 +0700] Allowing up to 100 client connections per host. I [24/Jul/2008:00:32:12 +0700] Using policy "default" as the default! I [24/Jul/2008:00:32:12 +0700] Full reload is required. I [24/Jul/2008:00:32:12 +0700] Loaded MIME database from '/etc/cups': 36 types, 39 filters... I [24/Jul/2008:00:32:12 +0700] Loading job cache file "/var/cache/cups/job.cache"... I [24/Jul/2008:00:32:12 +0700] Full reload complete. I [24/Jul/2008:00:32:12 +0700] Cleaning out old temporary files in "/var/spool/cups/tmp"... E [24/Jul/2008:00:32:12 +0700] Unable to open listen socket for address 127.0.0.1:631 - Permission denied. I [24/Jul/2008:00:32:12 +0700] Listening to /var/run/cups/cups.sock on fd 3... I [24/Jul/2008:00:32:12 +0700] Resuming new connection processing...


файл /etc/cups/cupsd.conf

Код:

Classification none DefaultCharset UTF-8 DefaultLanguage en Printcap /var/run/cups/printcap PrintcapFormat BSD RemoteRoot remroot SystemGroup lpadmin ServerCertificate /etc/cups/ssl/server.crt ServerKey /etc/cups/ssl/server.key <Location /> Encryption IfRequested Satisfy All Order allow,deny Allow localhost Allow @LOCAL </Location> <Location /admin> Encryption IfRequested Satisfy All Order allow,deny Allow localhost </Location> <Location /admin/conf> AuthType Basic Require user @SYSTEM Encryption IfRequested Satisfy All Order allow,deny Allow localhost </Location> HostnameLookups Off KeepAlive On KeepAliveTimeout 60 MaxClients 100 MaxRequestSize 0m Timeout 300 Listen localhost:631 Listen /var/run/cups/cups.sock:631 AccessLog /var/log/cups/access_log ErrorLog /var/log/cups/error_log PageLog /var/log/cups/page_log MaxLogSize 1m LogLevel info PreserveJobHistory On PreserveJobFiles Off AutoPurgeJobs No MaxJobs 0 MaxJobsPerPrinter 0 MaxJobsPerUser 0 User lp Group lpadmin RIPCache 8m FilterLimit 0 DataDir /usr/share/cups DocumentRoot /usr/share/cups/doc-root RequestRoot /var/spool/cups ServerBin /usr/lib/cups ServerRoot /etc/cups TempDir /var/spool/cups/tmp Browsing Off defaultauthtype Basic <policy default> <limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel$ require user @OWNER @SYSTEM order deny,allow </limit> <limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Releas$ authtype Basic require user @SYSTEM order deny,allow </limit> <limit Cancel-Job CUPS-Authenticate-Job> require user @OWNER @SYSTEM order deny,allow </limit> <limit All> order deny,allow </limit> </policy>


кто подскажет где проблему искать?
заранее спасибо!
Спасибо сказали:
Аватара пользователя
vr13
Сообщения: 887
ОС: gentoo

Re: не работает печать

Сообщение vr13 »

кто-нить сидит на порту 631? тут смотрели?
Спасибо сказали:
Najar
Сообщения: 6
ОС: Ubuntu 8.04

Re: не работает печать

Сообщение Najar »

да, забыл добавить: netstat -ltunp | grep 631 ничего не выводит
Спасибо сказали:
Аватара пользователя
vr13
Сообщения: 887
ОС: gentoo

Re: не работает печать

Сообщение vr13 »

а что он показывает?
и еще покажите, что показывает ifconfig
Спасибо сказали:
Najar
Сообщения: 6
ОС: Ubuntu 8.04

Re: не работает печать

Сообщение Najar »

vr13 писал(а): ↑
24.07.2008 11:19
а что он показывает?
и еще покажите, что показывает ifconfig


Код:

user@ubuntu:~$ sudo netstat -ltunpa | grep 631 user@ubuntu:~$


Код:

user@ubuntu:~$ ifconfig eth0 Link encap:Ethernet HWaddr 00:11:5b:c7:5d:23 inet addr:192.168.0.151 Bcast:192.168.0.255 Mask:255.255.255.0 inet6 addr: fe80::211:5bff:fec7:5d23/64 Диапазон:Ссылка ВВЕРХ BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:504725 errors:0 dropped:0 overruns:0 frame:0 TX packets:374057 errors:0 dropped:0 overruns:0 carrier:0 коллизии:0 txqueuelen:1000 RX bytes:373549036 (356.2 MB) TX bytes:103533712 (98.7 MB) Прервано:20 Base address:0xe400 lo Link encap:Локальная петля (Loopback) inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Диапазон:Узел ВВЕРХ LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:66455 errors:0 dropped:0 overruns:0 frame:0 TX packets:66455 errors:0 dropped:0 overruns:0 carrier:0 коллизии:0 txqueuelen:0 RX bytes:33291627 (31.7 MB) TX bytes:33291627 (31.7 MB) user@ubuntu:~$
Спасибо сказали:
Аватара пользователя
vr13
Сообщения: 887
ОС: gentoo

Re: не работает печать

Сообщение vr13 »

Najar писал(а): ↑
24.07.2008 13:07
vr13 писал(а): ↑
24.07.2008 11:19
а что он показывает?
и еще покажите, что показывает ifconfig



пардон, не верно сформулировал. что показывает

netstat -ltunpa|grep 127.0.0.1

и есть ли в /etc/hosts строчка (тоже покажите эту строчку)

127.0.0.1 ... localhost ...

если не тут, то просто не представляю где :)
Спасибо сказали:
Najar
Сообщения: 6
ОС: Ubuntu 8.04

Re: не работает печать

Сообщение Najar »

vr13 писал(а): ↑
24.07.2008 14:48
пардон, не верно сформулировал. что показывает

netstat -ltunpa|grep 127.0.0.1

и есть ли в /etc/hosts строчка (тоже покажите эту строчку)

127.0.0.1 ... localhost ...

если не тут, то просто не представляю где :)

Код:

root@ubuntu-atlant:/usr/src# netstat -ltunpa|grep 127.0.0.1 tcp 0 0 127.0.0.1:20001 0.0.0.0:* LISTEN 7713/netams tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 12097/mysqld tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 6262/exim4 tcp6 0 0 127.0.0.1:8005 :::* LISTEN 7771/java udp 0 0 127.0.0.1:2790 0.0.0.0:* 6906/winehasp udp 0 0 127.0.0.1:123 0.0.0.0:* 4977/ntpd root@ubuntu-atlant:/usr/src#


строчка в файле /etc/hosts есть

Код:

... 127.0.0.1 localhost ...

вот и я не представляю. прям хоть сноси все и заново ставь :(
Спасибо сказали:
wrx
Сообщения: 5

Re: не работает печать

Сообщение wrx »

никто не слушает 631.
вместо
>Listen localhost:631
попробуй пропиши
Port 631
BrowseAddress @IF(eth0) - сетевой интерфейс свой укажи
Listen localhost:631

потом перезапустиЖ:
/etc/init.d/cupsys restart
/etc/init.d/networking restart
Спасибо сказали:
Аватара пользователя
vr13
Сообщения: 887
ОС: gentoo

Re: не работает печать

Сообщение vr13 »

Najar писал(а): ↑
24.07.2008 15:21
вот и я не представляю. прям хоть сноси все и заново ставь :(


это не есть unix way :)

еще вопрос: кто владелец /usr/sbin/cupsd? это тоже root как, например, у exim4?
Спасибо сказали:
Najar
Сообщения: 6
ОС: Ubuntu 8.04

Re: не работает печать

Сообщение Najar »

wrx писал(а): ↑
24.07.2008 15:37
никто не слушает 631.
вместо
>Listen localhost:631
попробуй пропиши
Port 631
BrowseAddress @IF(eth0) - сетевой интерфейс свой укажи
Listen localhost:631

потом перезапустиЖ:
/etc/init.d/cupsys restart
/etc/init.d/networking restart

к сожалению не помогло

vr13 писал(а): ↑
24.07.2008 15:39
это не есть unix way :)

еще вопрос: кто владелец /usr/sbin/cupsd? это тоже root как, например, у exim4?

конечно не есть :)

Код:

root@ubuntu:/usr/src# ls -l /usr/sbin/cupsd -rwxr-xr-x 1 root root 382920 2008-04-22 03:18 /usr/sbin/cupsd root@ubuntu:/usr/src# ls -l /usr/sbin/exim4 -rwsr-xr-x 1 root root 691872 2008-02-02 10:18 /usr/sbin/exim4 root@ubuntu:/usr/src#
Спасибо сказали:
Аватара пользователя
vr13
Сообщения: 887
ОС: gentoo

Re: не работает печать

Сообщение vr13 »

попробуйте в конфиге вместо

listen localhost:631

написать

listen *:631

во всех конфигурациях, которые я вижу, написано как в первом случае, но мало ли может в ubuntu специфика какая есть..
Спасибо сказали:
Najar
Сообщения: 6
ОС: Ubuntu 8.04

Re: не работает печать

Сообщение Najar »

vr13 писал(а): ↑
24.07.2008 16:23
попробуйте в конфиге вместо

listen localhost:631

написать

listen *:631

во всех конфигурациях, которые я вижу, написано как в первом случае, но мало ли может в ubuntu специфика какая есть..

это тоже не помогло. на соседнем компьютере все работает. я даже конфиг от туда пробовал копировать. проблема обнаружилась после того как убрали контролер домена win2003, а так как комп был в домене то пришлось править PAM. может там что то неправильно сделал и с аунтефикацией проблема?
Спасибо сказали:
Аватара пользователя
vr13
Сообщения: 887
ОС: gentoo

Re: не работает печать

Сообщение vr13 »

Najar писал(а): ↑
25.07.2008 11:20
это тоже не помогло. на соседнем компьютере все работает. я даже конфиг от туда пробовал копировать. проблема обнаружилась после того как убрали контролер домена win2003, а так как комп был в домене то пришлось править PAM. может там что то неправильно сделал и с аунтефикацией проблема?


круто напрограммировано. ладно бы не печатал по причине аутентификации, а тут всего лишь сказать bind()/listen() надо. причем, судя по вашим логам, по unix domain сокету он все-таки слушает

а может быть наоборот правильно с т.з виндовсной аутентификации (сршенно не знаком) - там можно запретить пользователю со всеми правами на своем компьютере печатать на локальном принтере? если такое можно, то все наоборот верно, хотя это тоже не unix way :)
Спасибо сказали: