собственно проблема в том что принтер не печатает.
страница http://localhost:631 не открывается.
при старте cupsd в логе /var/log/cups/error_log:
Код:
I [24/Jul/2008:00:32:12 +0700] Loaded configuration file "/etc/cups/cupsd.conf"
N [24/Jul/2008:00:32:12 +0700] Group and SystemGroup cannot use the same groups!
I [24/Jul/2008:00:32:12 +0700] Resetting Group to "root"...
I [24/Jul/2008:00:32:12 +0700] Configured for up to 100 clients.
I [24/Jul/2008:00:32:12 +0700] Allowing up to 100 client connections per host.
I [24/Jul/2008:00:32:12 +0700] Using policy "default" as the default!
I [24/Jul/2008:00:32:12 +0700] Full reload is required.
I [24/Jul/2008:00:32:12 +0700] Loaded MIME database from '/etc/cups': 36 types, 39 filters...
I [24/Jul/2008:00:32:12 +0700] Loading job cache file "/var/cache/cups/job.cache"...
I [24/Jul/2008:00:32:12 +0700] Full reload complete.
I [24/Jul/2008:00:32:12 +0700] Cleaning out old temporary files in "/var/spool/cups/tmp"...
E [24/Jul/2008:00:32:12 +0700] Unable to open listen socket for address 127.0.0.1:631 - Permission denied.
I [24/Jul/2008:00:32:12 +0700] Listening to /var/run/cups/cups.sock on fd 3...
I [24/Jul/2008:00:32:12 +0700] Resuming new connection processing...
файл /etc/cups/cupsd.conf
Код:
Classification none
DefaultCharset UTF-8
DefaultLanguage en
Printcap /var/run/cups/printcap
PrintcapFormat BSD
RemoteRoot remroot
SystemGroup lpadmin
ServerCertificate /etc/cups/ssl/server.crt
ServerKey /etc/cups/ssl/server.key
<Location />
Encryption IfRequested
Satisfy All
Order allow,deny
Allow localhost
Allow @LOCAL
</Location>
<Location /admin>
Encryption IfRequested
Satisfy All
Order allow,deny
Allow localhost
</Location>
<Location /admin/conf>
AuthType Basic
Require user @SYSTEM
Encryption IfRequested
Satisfy All
Order allow,deny
Allow localhost
</Location>
HostnameLookups Off
KeepAlive On
KeepAliveTimeout 60
MaxClients 100
MaxRequestSize 0m
Timeout 300
Listen localhost:631
Listen /var/run/cups/cups.sock:631
AccessLog /var/log/cups/access_log
ErrorLog /var/log/cups/error_log
PageLog /var/log/cups/page_log
MaxLogSize 1m
LogLevel info
PreserveJobHistory On
PreserveJobFiles Off
AutoPurgeJobs No
MaxJobs 0
MaxJobsPerPrinter 0
MaxJobsPerUser 0
User lp
Group lpadmin
RIPCache 8m
FilterLimit 0
DataDir /usr/share/cups
DocumentRoot /usr/share/cups/doc-root
RequestRoot /var/spool/cups
ServerBin /usr/lib/cups
ServerRoot /etc/cups
TempDir /var/spool/cups/tmp
Browsing Off
defaultauthtype Basic
<policy default>
<limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel$
require user @OWNER @SYSTEM
order deny,allow
</limit>
<limit Pause-Printer Resume-Printer Set-Printer-Attributes Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Releas$
authtype Basic
require user @SYSTEM
order deny,allow
</limit>
<limit Cancel-Job CUPS-Authenticate-Job>
require user @OWNER @SYSTEM
order deny,allow
</limit>
<limit All>
order deny,allow
</limit>
</policy>
кто подскажет где проблему искать?
заранее спасибо!
никто не слушает 631.
вместо
>Listen localhost:631
попробуй пропиши
Port 631
BrowseAddress @IF(eth0) - сетевой интерфейс свой укажи
Listen localhost:631
потом перезапустиЖ:
/etc/init.d/cupsys restart
/etc/init.d/networking restart
никто не слушает 631.
вместо
>Listen localhost:631
попробуй пропиши
Port 631
BrowseAddress @IF(eth0) - сетевой интерфейс свой укажи
Listen localhost:631
потом перезапустиЖ:
/etc/init.d/cupsys restart
/etc/init.d/networking restart
во всех конфигурациях, которые я вижу, написано как в первом случае, но мало ли может в ubuntu специфика какая есть..
это тоже не помогло. на соседнем компьютере все работает. я даже конфиг от туда пробовал копировать. проблема обнаружилась после того как убрали контролер домена win2003, а так как комп был в домене то пришлось править PAM. может там что то неправильно сделал и с аунтефикацией проблема?
это тоже не помогло. на соседнем компьютере все работает. я даже конфиг от туда пробовал копировать. проблема обнаружилась после того как убрали контролер домена win2003, а так как комп был в домене то пришлось править PAM. может там что то неправильно сделал и с аунтефикацией проблема?
круто напрограммировано. ладно бы не печатал по причине аутентификации, а тут всего лишь сказать bind()/listen() надо. причем, судя по вашим логам, по unix domain сокету он все-таки слушает
а может быть наоборот правильно с т.з виндовсной аутентификации (сршенно не знаком) - там можно запретить пользователю со всеми правами на своем компьютере печатать на локальном принтере? если такое можно, то все наоборот верно, хотя это тоже не unix way